<!DOCTYPE html><html
lang="en-US" class="no-js"><head><meta
charset="UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="profile" href="http://gmpg.org/xfn/11">
<!--[if lt IE 9]> <script src="https://dailybulldog.com/wp-content/themes/fox/js/html5.js"></script> <![endif]--> <script>(function(html){html.className=html.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script> <title>Busy in the month of May &#8211; Daily Bulldog</title><link
rel='dns-prefetch' href='//fonts.googleapis.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link
rel="alternate" type="application/rss+xml" title="Daily Bulldog &raquo; Feed" href="https://dailybulldog.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="Daily Bulldog &raquo; Comments Feed" href="https://dailybulldog.com/comments/feed/" /><link
rel="alternate" type="text/calendar" title="Daily Bulldog &raquo; iCal Feed" href="https://dailybulldog.com/events/?ical=1" /><link
rel="alternate" type="application/rss+xml" title="Daily Bulldog &raquo; Busy in the month of May Comments Feed" href="https://dailybulldog.com/features/busy-in-the-month-of-may/feed/" />
 <script src="//www.googletagmanager.com/gtag/js?id=UA-4957997-1"  type="text/javascript" data-cfasync="false"></script> <script type="text/javascript" data-cfasync="false">var mi_version='7.17.0';var mi_track_user=!0;var mi_no_track_reason='';var disableStr='ga-disable-UA-4957997-1';function __gtagTrackerIsOptedOut(){return document.cookie.indexOf(disableStr+'=true')>-1}
if(__gtagTrackerIsOptedOut()){window[disableStr]=!0}
function __gtagTrackerOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';window[disableStr]=!0}
if('undefined'===typeof gaOptout){function gaOptout(){__gtagTrackerOptout()}}
window.dataLayer=window.dataLayer||[];if(mi_track_user){function __gtagTracker(){dataLayer.push(arguments)}
__gtagTracker('js',new Date());__gtagTracker('set',{'developer_id.dZGIzZG':!0,});__gtagTracker('config','UA-4957997-1',{forceSSL:!0,link_attribution:!0,});window.gtag=__gtagTracker;(function(){var noopfn=function(){return null};var newtracker=function(){return new Tracker()};var Tracker=function(){return null};var p=Tracker.prototype;p.get=noopfn;p.set=noopfn;p.send=function(){var args=Array.prototype.slice.call(arguments);args.unshift('send');__gaTracker.apply(null,args)};var __gaTracker=function(){var len=arguments.length;if(len===0){return}
var f=arguments[len-1];if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){if('send'===arguments[0]){var hitConverted,hitObject=!1,action;if('event'===arguments[1]){if('undefined'!==typeof arguments[3]){hitObject={'eventAction':arguments[3],'eventCategory':arguments[2],'eventLabel':arguments[4],'value':arguments[5]?arguments[5]:1,}}}
if(typeof arguments[2]==='object'){hitObject=arguments[2]}
if(typeof arguments[5]==='object'){Object.assign(hitObject,arguments[5])}
if('undefined'!==typeof(arguments[1].hitType)){hitObject=arguments[1]}
if(hitObject){action='timing'===arguments[1].hitType?'timing_complete':hitObject.eventAction;hitConverted=mapArgs(hitObject);__gtagTracker('event',action,hitConverted)}}
return}
function mapArgs(args){var gaKey,hit={};var gaMap={'eventCategory':'event_category','eventAction':'event_action','eventLabel':'event_label','eventValue':'event_value','nonInteraction':'non_interaction','timingCategory':'event_category','timingVar':'name','timingValue':'value','timingLabel':'event_label',};for(gaKey in gaMap){if('undefined'!==typeof args[gaKey]){hit[gaMap[gaKey]]=args[gaKey]}}
return hit}
try{f.hitCallback()}catch(ex){}};__gaTracker.create=newtracker;__gaTracker.getByName=newtracker;__gaTracker.getAll=function(){return[]};__gaTracker.remove=noopfn;__gaTracker.loaded=!0;window.__gaTracker=__gaTracker})()}else{console.log("");(function(){function __gtagTracker(){return null}
window.__gtagTracker=__gtagTracker;window.gtag=__gtagTracker})()}</script> 
<script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}()</script> <link
rel='stylesheet' id='SH_CSS-css'  href='https://dailybulldog.com/wp-content/plugins/SH_CSS/SH_CSS.css?v=6&#038;ver=5.5.5' media='all' /><link
rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://dailybulldog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' media='all' /><link
rel='stylesheet' id='tribe-tooltip-css'  href='https://dailybulldog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' media='all' /><link
rel='stylesheet' id='wp-block-library-css'  href='https://dailybulldog.com/wp-includes/css/dist/block-library/style.min.css' media='all' /><link
rel='stylesheet' id='awesome-weather-css'  href='https://dailybulldog.com/wp-content/plugins/awesome-weather/awesome-weather.css' media='all' /><style id='awesome-weather-inline-css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style><link
rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.5.5' media='all' /><link
rel='stylesheet' id='contact-form-7-css'  href='https://dailybulldog.com/wp-content/plugins/contact-form-7/includes/css/styles.css' media='all' /><link
rel='stylesheet' id='simple-banner-style-css'  href='https://dailybulldog.com/wp-content/plugins/simple-banner/simple-banner.css' media='all' /><link
rel='stylesheet' id='wi-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700%2C800%2C400italic%2C600%7CPathway+Gothic+One%3A400&#038;display=swap&#038;ver=4.6.1.1' media='all' /><link
rel='stylesheet' id='mediaelement-css'  href='https://dailybulldog.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' media='all' /><link
rel='stylesheet' id='wp-mediaelement-css'  href='https://dailybulldog.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' media='all' /><link
rel='stylesheet' id='style-css'  href='https://dailybulldog.com/wp-content/themes/fox/style.min.css' media='all' /><style id='style-inline-css'>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</style><link
rel='stylesheet' id='awpcp-font-awesome-css'  href='https://use.fontawesome.com/releases/v5.2.0/css/all.css' media='all' /><link
rel='stylesheet' id='awpcp-frontend-style-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css' media='all' />
<!--[if lte IE 6]><link
rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' media='all' />
<![endif]-->
<!--[if lte IE 7]><link
rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' media='all' />
<![endif]--><link
rel='stylesheet' id='csshero-main-stylesheet-css'  href='https://dailybulldog.com/wp-content/uploads/2021/03/csshero-static-style-fox.css' media='all' /> <script id='wpo_min-header-0-js-extra'>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</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1620056726/assets/wpo-minify-header-c4711bc6.min.js' id='wpo_min-header-0-js'></script> <link
rel="https://api.w.org/" href="https://dailybulldog.com/wp-json/" /><link
rel="alternate" type="application/json" href="https://dailybulldog.com/wp-json/wp/v2/posts/175891" /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dailybulldog.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dailybulldog.com/wp-includes/wlwmanifest.xml" /><link
rel='prev' title='Letter to the editor: No to NECEC, Yes in November' href='https://dailybulldog.com/opinion/letter-to-the-editor-no-to-necec-yes-in-november/' /><link
rel='next' title='Gov. Mills stops by benefit plant sale' href='https://dailybulldog.com/happenings/gov-mills-stops-by-benefit-plant-sale/' /><meta
name="generator" content="WordPress 5.5.5" /><link
rel='shortlink' href='https://dailybulldog.com/?p=175891' /><link
rel="alternate" type="application/json+oembed" href="https://dailybulldog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://dailybulldog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;format=xml" /><meta
property="fb:app_id" content=""/><meta
property="fb:admins" content=""/><style type="text/css">@media screen{.printfriendly{position:relative;z-index:1000;margin:0 0 0 0}.printfriendly a,.printfriendly a:link,.printfriendly a:visited,.printfriendly a:hover,.printfriendly a:active{font-weight:600;cursor:pointer;text-decoration:none;border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;outline:none;font-size:14px!important;color:#55750C!important}.printfriendly.pf-alignleft{float:left}.printfriendly.pf-alignright{float:right}.printfriendly.pf-aligncenter{display:flex;align-items:center;justify-content:center}}@media print{.printfriendly{display:none}}</style><style type="text/css" media="screen">.simple-banner{position:initial}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text{font-size:17px}</style><style type="text/css" media="screen">.simple-banner{background:#b5b8ba}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text{color:#fff}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text a{color:#f16521}</style><style id="simple-banner-site-custom-css-dummy" type="text/css" media="screen"></style><script id="simple-banner-site-custom-js-dummy" type="text/javascript"></script><meta
name="tec-api-version" content="v1"><meta
name="tec-api-origin" content="https://dailybulldog.com"><link
rel="https://theeventscalendar.com/" href="https://dailybulldog.com/wp-json/tribe/events/v1/" /><meta
property="og:image" content="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-2-e1621116536951.jpg"/><meta
property="og:image:secure_url" content="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-2-e1621116536951.jpg" /><link
rel="canonical" href="https://dailybulldog.com/features/busy-in-the-month-of-may/" /><style id="wp-custom-css">@media screen and (min-width:568px){body.home li.tribe-events-list-widget-events{width:25%!important;float:left!important}}.tribe-clearfix.tribe-events-category-meetings.tribe-event-featured{border:none!important;margin-top:0!important;margin-bottom:0!important;padding-bottom:0!important}.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event{background-color:transparent!important}</style><style id="color-preview"></style></head><body
class="post-template-default single single-post postid-175891 single-format-standard tribe-no-js page-template-var-www-dailybulldog-com-wp-content-themes-fox-page-php tribe-theme-fox layout-wide style--dropcap-dark dropcap-style-dark style--dropcap-font-heading style--tag-block-2 style--tag-block style--list-widget-1 style--tagcloud-1 style--blockquote-no-icon style--single-heading-border_top style--link-1 elementor-default elementor-kit-164798 aa-prefix-daily-" itemscope itemtype="https://schema.org/WebPage"><div
id="wi-all" class="fox-outer-wrapper fox-all wi-all"><div
id="wi-wrapper" class="fox-wrapper wi-wrapper"><div
class="wi-container"><header
id="masthead" class="site-header header-classic header-sticky-style-shadow submenu-light" itemscope itemtype="https://schema.org/WPHeader"><div
class="header-container header-stack3 header-nav-top-3 header-nav-bottom-1"><div
class="header-classic-row header-row-branding header-row-main header-stack3-main"><div
class="container"><div
id="logo-area" class="fox-logo-area fox-header-logo site-branding"><div
id="wi-logo" class="fox-logo-container"><h2 class="wi-logo-main fox-logo logo-type-image" id="site-logo">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Logo" class="main-img-logo" />
</a></h2></div><h3 class="slogan site-description">Franklin County&#039;s First News</h3></div><div
class="header-stack3-left header-stack3-part">
<a
class="toggle-menu hamburger hamburger-btn">
<i
class="feather-menu"></i>
<i
class="feather-x"></i>
</a><div
class="header-search-wrapper header-search-classic">
<span
class="search-btn-classic search-btn">
<i
class="fa fa-search"></i>    </span><div
class="header-search-form header-search-form-template"><div
class="container"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div></div></div></div><div
class="header-stack3-right header-stack3-part"><div
class="social-list header-social style-plain shape-circle align-center icon-size-normal icon-spacing-small style-none" id="social-id-60a1bcda0353d"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div></div></div></div><div
class="row-nav-light row-nav-style-active-4 header-classic-row header-row-nav header-sticky-element"><div
class="container"><nav
id="wi-mainnav" class="navigation-ele wi-mainnav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div
class="menu style-indicator-angle-down"><ul
id="menu-main-menu" class="menu"><li
id="menu-item-6645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6645"><a
href="https://dailybulldog.com/category/news/">News</a></li><li
id="menu-item-164857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-164857"><a
href="https://dailybulldog.com/category/business/">Business</a><ul
class="sub-menu"><li
id="menu-item-165089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165089"><a
href="https://dailybulldog.com/business-directory/">Directory</a></li></ul></li><li
id="menu-item-170580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170580"><a
href="https://dailybulldog.com/category/happenings/">Happenings</a></li><li
id="menu-item-164805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164805"><a
href="https://dailybulldog.com/category/arts/">Arts</a></li><li
id="menu-item-171125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171125"><a
href="https://dailybulldog.com/category/food/">Food</a></li><li
id="menu-item-164854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164854"><a
href="https://dailybulldog.com/category/sports/">Sports</a></li><li
id="menu-item-164858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164858"><a
href="https://dailybulldog.com/category/outdoors/">Outdoors</a></li><li
id="menu-item-164859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164859"><a
href="https://dailybulldog.com/category/health/">Health</a></li><li
id="menu-item-164856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164856"><a
href="https://dailybulldog.com/category/obituaries/">Obituaries</a></li><li
id="menu-item-164855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164855"><a
href="https://dailybulldog.com/category/opinion/">Opinion</a></li><li
id="menu-item-164848" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-164848"><a
href="https://dailybulldog.com/events/">Events</a></li><li
id="menu-item-164869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164869"><a
href="https://dailybulldog.com/classifieds-2/">Classifieds</a></li></ul></div></nav></div></div></div><div
id="after-header" class="widget-area header-sidebar wide-sidebar header-row after-header align-center"><div
class="container"><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1145196184"><a
href="https://androscoggin.org/careers/"><img
loading="lazy" src="https://dailybulldog.com/wp-content/uploads/2021/04/DBD-Banner_Hiring.png" alt=""  width="1200" height="144"  style="display: inline-block;" /></a></div></div></div></div></header><div
id="masthead-mobile" class="masthead-mobile"><div
class="container"><div
class="masthead-mobile-left masthead-mobile-part">
<a
class="toggle-menu hamburger hamburger-btn">
<i
class="feather-menu"></i>
<i
class="feather-x"></i>
</a></div><h4 id="mobile-logo" class="mobile-logo mobile-logo-image">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Mobile Logo" />
</a></h4><div
class="masthead-mobile-right masthead-mobile-part"></div></div><div
class="masthead-mobile-bg"></div></div><div
id="masthead-mobile-height"></div><div
id="wi-main" class="wi-main fox-main"><article
id="wi-content" class="wi-content wi-single single-style-2 padding-top-normal post-175891 post type-post status-publish format-standard has-post-thumbnail hentry category-features has-sidebar sidebar-right" itemscope itemtype="https://schema.org/CreativeWork"><header
class="single-header post-header entry-header single-big-section align-left single-header-template-4" itemscope itemtype="https://schema.org/WPHeader"><div
class="container"><div
class="header-main"><div
class="post-item-header"><div
class="entry-categories meta-categories categories-plain standalone-categories post-header-section"><a
href="https://dailybulldog.com/category/features/" rel="tag">Features</a></div><div
class="title-subtitle"><h1 class="post-title post-item-title">Busy in the month of May</h1></div><div
class="post-item-meta wi-meta fox-meta post-header-section "><div
class="fox-meta-author entry-author meta-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a
class="meta-author-avatar" itemprop="url" rel="author" href="https://dailybulldog.com/author/administrator/"></a><span
class="byline"> by <span
class="author vcard"><a
class="url fn" itemprop="url" rel="author" href="https://dailybulldog.com/author/administrator/"><span
itemprop="name">Administrator</span></a></span></span></div><div
class="entry-date meta-time machine-time time-short"><time
class="published updated" itemprop="datePublished" datetime="2021-05-16T10:54:48-04:00">May 16, 2021</time></div><div
class="reading-time">8 mins read</div></div></div></div></div></header><div
class="single-big-section single-big-section-content"><div
class="container"><div
id="primary" class="primary content-area"><div
class="theiaStickySidebar"><div
class="single-body single-section"><div
class="single-section single-main-content disable-dropcap"><div
class="entry-container"><div
class="content-main"><div
class="dropcap-content columnable-content entry-content single-component"><div
class="pf-content"><figure
id="attachment_175901" aria-describedby="caption-attachment-175901" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-2-e1621116536951.jpg"><img
loading="lazy" class="size-full wp-image-175901" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-2-e1621116536951.jpg" alt="" width="600" height="650" /></a><figcaption
id="caption-attachment-175901" class="wp-caption-text">Nashville warbler in flight in Wilton. (Photo by Tom Oliver)</figcaption></figure><figure
id="attachment_175898" aria-describedby="caption-attachment-175898" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-6-e1621116418615.jpg"><img
loading="lazy" class="size-full wp-image-175898" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-6-e1621116418615.jpg" alt="" width="600" height="487" /></a><figcaption
id="caption-attachment-175898" class="wp-caption-text">Ovenbird in Wilton. (Photo by Tom Oliver)</figcaption></figure><figure
id="attachment_175899" aria-describedby="caption-attachment-175899" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-2-e1621116445541.jpg"><img
loading="lazy" class="size-full wp-image-175899" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-2-e1621116445541.jpg" alt="" width="600" height="573" /></a><figcaption
id="caption-attachment-175899" class="wp-caption-text">Tree swallow with nest-building material in Wilton. (Photo by Tom Oliver)</figcaption></figure><figure
id="attachment_175900" aria-describedby="caption-attachment-175900" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-2-e1621116496379.jpg"><img
loading="lazy" class="size-full wp-image-175900" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-2-e1621116496379.jpg" alt="" width="600" height="528" /></a><figcaption
id="caption-attachment-175900" class="wp-caption-text">Prairie warbler in Augusta. (Photo by Tom Oliver)</figcaption></figure><figure
id="attachment_175902" aria-describedby="caption-attachment-175902" style="width: 500px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-4-1.jpg"><img
loading="lazy" class="size-full wp-image-175902" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-4-1.jpg" alt="" width="500" height="480" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-4-1.jpg 500w, https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-4-1-300x288.jpg 300w, https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-4-1-480x461.jpg 480w" sizes="(max-width: 500px) 100vw, 500px" /></a><figcaption
id="caption-attachment-175902" class="wp-caption-text">Northern harrier soaring over the fields at the head of Wilson Lake in Wilton. (Photo by Tom Oliver)</figcaption></figure><figure
id="attachment_175940" aria-describedby="caption-attachment-175940" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-7-e1621175848809.jpg"><img
loading="lazy" class="size-full wp-image-175940" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-7-e1621175848809.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175940" class="wp-caption-text">Virginia rail at the University of Maine, Orono, Cornfield Loop Marsh. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175941" aria-describedby="caption-attachment-175941" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-3-e1621175906277.jpg"><img
loading="lazy" class="size-full wp-image-175941" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-3-e1621175906277.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175941" class="wp-caption-text">Sora  at the University of Maine, Orono, Cornfield Loop Marsh. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175942" aria-describedby="caption-attachment-175942" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-3-e1621175966719.jpg"><img
loading="lazy" class="size-full wp-image-175942" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-3-e1621175966719.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175942" class="wp-caption-text">My guess on this is a Magnolia Tuliptree blossom at the Littlefield Ornamentals Trial Garden, University of Maine, Orono. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175944" aria-describedby="caption-attachment-175944" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-3-e1621176059989.jpg"><img
loading="lazy" class="size-full wp-image-175944" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-3-e1621176059989.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175944" class="wp-caption-text">Grey catbird at the Littlefield Ornamentals Trial Garden, University of Maine, Orono. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175945" aria-describedby="caption-attachment-175945" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-8-e1621176113514.jpg"><img
loading="lazy" class="size-full wp-image-175945" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-8-e1621176113514.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175945" class="wp-caption-text">Tulip Trio, Littlefield Ornamentals Trial Garden, University of Maine, Orono. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175946" aria-describedby="caption-attachment-175946" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-4-e1621176160182.jpg"><img
loading="lazy" class="size-full wp-image-175946" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-1-4-e1621176160182.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175946" class="wp-caption-text">Dew on Tuliptree Petal, Littlefield Ornamentals Trial Garden, University of Maine, Orono. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175947" aria-describedby="caption-attachment-175947" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-4-e1621176250336.jpg"><img
loading="lazy" class="size-full wp-image-175947" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-2-4-e1621176250336.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175947" class="wp-caption-text">Brown thrasher at the University of Maine at Farmington fields near Narrow Gauge Trail. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175948" aria-describedby="caption-attachment-175948" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-4-e1621176306405.jpg"><img
loading="lazy" class="size-full wp-image-175948" src="https://dailybulldog.com/wp-content/uploads/2021/05/unnamed-3-4-e1621176306405.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175948" class="wp-caption-text">Ruby-throated hummingbird working crabapple blossoms, Narrow Gauge Trail in Farmington. (Photo by Steve Muise, Farmington)</figcaption></figure><figure
id="attachment_175892" aria-describedby="caption-attachment-175892" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05800-e1621115803303.jpg"><img
loading="lazy" class="size-full wp-image-175892" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05800-e1621115803303.jpg" alt="" width="600" height="450" /></a><figcaption
id="caption-attachment-175892" class="wp-caption-text">Pileated woodpecker in Weld. (Photo by Dennis York)</figcaption></figure><figure
id="attachment_175893" aria-describedby="caption-attachment-175893" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05821-e1621115885703.jpg"><img
loading="lazy" class="size-full wp-image-175893" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05821-e1621115885703.jpg" alt="" width="600" height="450" /></a><figcaption
id="caption-attachment-175893" class="wp-caption-text">A green heron in Wilton. (Photo by Dennis York)</figcaption></figure><figure
id="attachment_175894" aria-describedby="caption-attachment-175894" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05829-e1621115935359.jpg"><img
loading="lazy" class="size-full wp-image-175894" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05829-e1621115935359.jpg" alt="" width="600" height="450" /></a><figcaption
id="caption-attachment-175894" class="wp-caption-text">Robin chicks at one day old. (Photo by Dennis York)</figcaption></figure><figure
id="attachment_175895" aria-describedby="caption-attachment-175895" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05832-e1621115993925.jpg"><img
loading="lazy" class="size-full wp-image-175895" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05832-e1621115993925.jpg" alt="" width="600" height="450" /></a><figcaption
id="caption-attachment-175895" class="wp-caption-text">A red winged blackbird watches as everything turns green. (Photo by Dennis York)</figcaption></figure><figure
id="attachment_175897" aria-describedby="caption-attachment-175897" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05849-e1621116218791.jpg"><img
loading="lazy" class="size-full wp-image-175897" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC05849-e1621116218791.jpg" alt="" width="600" height="450" /></a><figcaption
id="caption-attachment-175897" class="wp-caption-text">Very effective camouflage for this American bittern in the cattails. (Photo by Dennis York)</figcaption></figure><figure
id="attachment_175918" aria-describedby="caption-attachment-175918" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/J4A3008-1-e1621172664258.jpg"><img
loading="lazy" class="size-full wp-image-175918" src="https://dailybulldog.com/wp-content/uploads/2021/05/J4A3008-1-e1621172664258.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175918" class="wp-caption-text">Red fox kits in Farmington. There were three in the culvert. (Photo by David Pike)</figcaption></figure><figure
id="attachment_175919" aria-describedby="caption-attachment-175919" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/J4A3016-1-e1621172715363.jpg"><img
loading="lazy" class="size-full wp-image-175919" src="https://dailybulldog.com/wp-content/uploads/2021/05/J4A3016-1-e1621172715363.jpg" alt="" width="600" height="400" /></a><figcaption
id="caption-attachment-175919" class="wp-caption-text">Red fox kit in Farmington. (Photo by David Pike)</figcaption></figure><figure
id="attachment_175903" aria-describedby="caption-attachment-175903" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0147-2-scaled-e1621116929299.jpg"><img
loading="lazy" class="size-full wp-image-175903" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0147-2-scaled-e1621116929299.jpg" alt="" width="600" height="398" /></a><figcaption
id="caption-attachment-175903" class="wp-caption-text">Tulips and daffodils blend in this field off High Street in Wilton. (Photo by Don Waterhouse)</figcaption></figure><figure
id="attachment_175904" aria-describedby="caption-attachment-175904" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0185-2-scaled-e1621117021266.jpg"><img
loading="lazy" class="size-full wp-image-175904" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0185-2-scaled-e1621117021266.jpg" alt="" width="600" height="398" /></a><figcaption
id="caption-attachment-175904" class="wp-caption-text">Blossoms are in full bloom on these trees along Main Street in Farmington. (Photo by Don Waterhouse)</figcaption></figure><figure
id="attachment_175913" aria-describedby="caption-attachment-175913" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0171-scaled-e1621168499564.jpg"><img
loading="lazy" class="size-full wp-image-175913" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0171-scaled-e1621168499564.jpg" alt="" width="600" height="398" /></a><figcaption
id="caption-attachment-175913" class="wp-caption-text">Tulips, daffodils, dandelions, and forget-me-nots, combine for a colorful array. (Photo by Don Waterhouse)</figcaption></figure><figure
id="attachment_175905" aria-describedby="caption-attachment-175905" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0053-2-scaled-e1621117096831.jpg"><img
loading="lazy" class="size-full wp-image-175905" src="https://dailybulldog.com/wp-content/uploads/2021/05/DSC_0053-2-scaled-e1621117096831.jpg" alt="" width="600" height="398" /></a><figcaption
id="caption-attachment-175905" class="wp-caption-text">Portland Head Light stands out under a dramatic sky. (Photo by Don Waterhouse)</figcaption></figure><figure
id="attachment_175906" aria-describedby="caption-attachment-175906" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/m11b7574-4-scaled-e1621117398346.jpg"><img
loading="lazy" class="size-full wp-image-175906" src="https://dailybulldog.com/wp-content/uploads/2021/05/m11b7574-4-scaled-e1621117398346.jpg" alt="" width="600" height="388" /></a><figcaption
id="caption-attachment-175906" class="wp-caption-text">A purple finch stops long enough for me to take a picture in Wilton. ( Photo by Jim Knox)</figcaption></figure><figure
id="attachment_175907" aria-describedby="caption-attachment-175907" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7447-4-e1621117428776.jpg"><img
loading="lazy" class="size-full wp-image-175907" src="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7447-4-e1621117428776.jpg" alt="" width="600" height="368" /></a><figcaption
id="caption-attachment-175907" class="wp-caption-text">Most folks are now seeing the rose-breasted grosbeak in their area. This one in Wilton. (Photo by Jim Knox)</figcaption></figure><figure
id="attachment_175908" aria-describedby="caption-attachment-175908" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7116-3-scaled-e1621117463916.jpg"><img
loading="lazy" class="size-full wp-image-175908" src="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7116-3-scaled-e1621117463916.jpg" alt="" width="600" height="393" /></a><figcaption
id="caption-attachment-175908" class="wp-caption-text">The Baltimore oriole is back in Wilton. (Photo by Jim Knox )</figcaption></figure><figure
id="attachment_175909" aria-describedby="caption-attachment-175909" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7291-3-scaled-e1621117489312.jpg"><img
loading="lazy" class="size-full wp-image-175909" src="https://dailybulldog.com/wp-content/uploads/2021/05/M11B7291-3-scaled-e1621117489312.jpg" alt="" width="600" height="309" /></a><figcaption
id="caption-attachment-175909" class="wp-caption-text">Orioles sure love oranges. (Photo by Jim Knox )</figcaption></figure><figure
id="attachment_175910" aria-describedby="caption-attachment-175910" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/M11B6807-2-e1621117516662.jpg"><img
loading="lazy" class="size-full wp-image-175910" src="https://dailybulldog.com/wp-content/uploads/2021/05/M11B6807-2-e1621117516662.jpg" alt="" width="600" height="391" /></a><figcaption
id="caption-attachment-175910" class="wp-caption-text">You never know who&#8217;s going to pop up in front of you! In Livermore. ( Photo by Jim Knox)</figcaption></figure><figure
id="attachment_175920" aria-describedby="caption-attachment-175920" style="width: 574px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.18-AM.png"><img
loading="lazy" class="size-full wp-image-175920" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.18-AM.png" alt="" width="574" height="447" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.18-AM.png 574w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.18-AM-300x234.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.18-AM-480x374.png 480w" sizes="(max-width: 574px) 100vw, 574px" /></a><figcaption
id="caption-attachment-175920" class="wp-caption-text">A fine day to be a sheep. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175921" aria-describedby="caption-attachment-175921" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/chipping-sparrow-in-reeds-e1621173549141.jpg"><img
loading="lazy" class="size-full wp-image-175921" src="https://dailybulldog.com/wp-content/uploads/2021/05/chipping-sparrow-in-reeds-e1621173549141.jpg" alt="" width="600" height="515" /></a><figcaption
id="caption-attachment-175921" class="wp-caption-text">A chirping sparrow rests on reeds in Vienna&#8217;s Mill Pond. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175922" aria-describedby="caption-attachment-175922" style="width: 411px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.42-AM.png"><img
loading="lazy" class="size-full wp-image-175922" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.42-AM.png" alt="" width="411" height="454" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.42-AM.png 411w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.42-AM-272x300.png 272w" sizes="(max-width: 411px) 100vw, 411px" /></a><figcaption
id="caption-attachment-175922" class="wp-caption-text">Year after year daffodils signal spring. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175923" aria-describedby="caption-attachment-175923" style="width: 494px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.59-AM.png"><img
loading="lazy" class="size-full wp-image-175923" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.59-AM.png" alt="" width="494" height="455" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.59-AM.png 494w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.59-AM-300x276.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-9.48.59-AM-480x442.png 480w" sizes="(max-width: 494px) 100vw, 494px" /></a><figcaption
id="caption-attachment-175923" class="wp-caption-text">An eastern king bird on Parker Pond. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175924" aria-describedby="caption-attachment-175924" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.00.51-AM-e1621173738499.png"><img
loading="lazy" class="size-full wp-image-175924" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.00.51-AM-e1621173738499.png" alt="" width="600" height="439" /></a><figcaption
id="caption-attachment-175924" class="wp-caption-text">Passing through: a female Baltimore oriole. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175925" aria-describedby="caption-attachment-175925" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.01.04-AM-e1621173760850.png"><img
loading="lazy" class="size-full wp-image-175925" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.01.04-AM-e1621173760850.png" alt="" width="600" height="406" /></a><figcaption
id="caption-attachment-175925" class="wp-caption-text">Mrs. Oriole takes a jelly break. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175926" aria-describedby="caption-attachment-175926" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.01.22-AM-e1621173798353.png"><img
loading="lazy" class="size-full wp-image-175926" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.01.22-AM-e1621173798353.png" alt="" width="600" height="388" /></a><figcaption
id="caption-attachment-175926" class="wp-caption-text">A feather on Papa Goose acts like a tiny sail, or possibly needs some hair gel. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175927" aria-describedby="caption-attachment-175927" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/goslings-up-close-e1621173997187.jpg"><img
loading="lazy" class="size-full wp-image-175927" src="https://dailybulldog.com/wp-content/uploads/2021/05/goslings-up-close-e1621173997187.jpg" alt="" width="600" height="485" /></a><figcaption
id="caption-attachment-175927" class="wp-caption-text">Up close with goslings on Torsey Pond in Kents Hill. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175928" aria-describedby="caption-attachment-175928" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.04.43-AM-e1621174033764.png"><img
loading="lazy" class="size-full wp-image-175928" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.04.43-AM-e1621174033764.png" alt="" width="600" height="417" /></a><figcaption
id="caption-attachment-175928" class="wp-caption-text">When all of your goslings are in a row, all&#8217;s right with the world. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175930" aria-describedby="caption-attachment-175930" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/grackle-e1621174057547.jpg"><img
loading="lazy" class="size-full wp-image-175930" src="https://dailybulldog.com/wp-content/uploads/2021/05/grackle-e1621174057547.jpg" alt="" width="600" height="452" /></a><figcaption
id="caption-attachment-175930" class="wp-caption-text">A common grackle inches closer to the water&#8217;s edge of Vienna&#8217;s Mill Pond. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175929" aria-describedby="caption-attachment-175929" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.05.22-AM-e1621174105350.png"><img
loading="lazy" class="size-full wp-image-175929" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.05.22-AM-e1621174105350.png" alt="" width="600" height="392" /></a><figcaption
id="caption-attachment-175929" class="wp-caption-text">A sharp shinned hawk surveys Parker Pond and its bog. (Photo by Jane Naliboff) (Is it a sharp shinned or a Cooper&#8217;s? For the sake of identification: The Cooper&#8217;s hawk has a more prominent head that is block-like and dome-shaped, while a sharp-shinned hawk has a smaller, more rounded head. &#8230; The tail of a Cooper&#8217;s hawk is typically rounded, while a sharp-shinned hawk has tail feathers with a straight or flat edge, according to the Audubon Society.Sep 23, 2019.)</figcaption></figure><figure
id="attachment_175933" aria-describedby="caption-attachment-175933" style="width: 564px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.06-AM.png"><img
loading="lazy" class="size-full wp-image-175933" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.06-AM.png" alt="" width="564" height="455" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.06-AM.png 564w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.06-AM-300x242.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.06-AM-480x387.png 480w" sizes="(max-width: 564px) 100vw, 564px" /></a><figcaption
id="caption-attachment-175933" class="wp-caption-text">A swallow looks out of a nesting box in Vienna. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175934" aria-describedby="caption-attachment-175934" style="width: 509px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.33-AM.png"><img
loading="lazy" class="size-full wp-image-175934" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.33-AM.png" alt="" width="509" height="457" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.33-AM.png 509w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.33-AM-300x269.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.33-AM-480x431.png 480w" sizes="(max-width: 509px) 100vw, 509px" /></a><figcaption
id="caption-attachment-175934" class="wp-caption-text">A swallow checks on nest progress in Vienna. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175935" aria-describedby="caption-attachment-175935" style="width: 505px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.48-AM.png"><img
loading="lazy" class="size-full wp-image-175935" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.48-AM.png" alt="" width="505" height="459" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.48-AM.png 505w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.48-AM-300x273.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.09.48-AM-480x436.png 480w" sizes="(max-width: 505px) 100vw, 505px" /></a><figcaption
id="caption-attachment-175935" class="wp-caption-text">A robin waits for nest building reinforcements. Eggs should be coming soon. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175936" aria-describedby="caption-attachment-175936" style="width: 534px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.13.46-AM.png"><img
loading="lazy" class="size-full wp-image-175936" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.13.46-AM.png" alt="" width="534" height="452" srcset="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.13.46-AM.png 534w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.13.46-AM-300x254.png 300w, https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.13.46-AM-480x406.png 480w" sizes="(max-width: 534px) 100vw, 534px" /></a><figcaption
id="caption-attachment-175936" class="wp-caption-text">Little Red eats his leafy greens everyday like a good little squirrel. Unfortunately, he chose a perennial from the garden and cleaned his plate. (Photo by Jane Naliboff)</figcaption></figure><figure
id="attachment_175937" aria-describedby="caption-attachment-175937" style="width: 600px" class="wp-caption aligncenter"><a
href="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.14.09-AM-e1621174534752.png"><img
loading="lazy" class="size-full wp-image-175937" src="https://dailybulldog.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-16-at-10.14.09-AM-e1621174534752.png" alt="" width="600" height="343" /></a><figcaption
id="caption-attachment-175937" class="wp-caption-text">Little Chip on the run. (Photo by Jane Naliboff)</figcaption></figure><div
class="printfriendly pf-button pf-button-content pf-alignright"><a
href="#" rel="nofollow" onclick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img
style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="https://cdn.printfriendly.com/buttons/printfriendly-button.png" alt="Print Friendly, PDF & Email" /></a></div><style>.pf-button.pf-button-excerpt{display:none}</style></div><div
class="fb-like" data-href="https://dailybulldog.com/features/busy-in-the-month-of-may/" data-layout="standard" data-action="like" data-show-faces="true" data-share="on"></div></div><div
class="single-component single-component-share"><div
class="fox-share share-style-2b share-style-default  background-brand share-layout-stack">
<span
class="share-label"><i
class="fa fa-share-alt"></i>Share this</span><ul><li
class="li-share-facebook">
<a
href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F" title="Facebook" class="share share-facebook">
<i
class="fab fa-facebook-f"></i>
<span>Facebook</span>
</a></li><li
class="li-share-messenger">
<a
href="https://www.facebook.com/dialog/send?app_id=794927004237856&#038;link=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;redirect_uri=https%3A%2F%2Fdailybulldog.com%2F" title="Messenger" class="share share-messenger">
<i
class="fab fa-facebook-messenger"></i>
<span>Messenger</span>
</a></li><li
class="li-share-twitter">
<a
href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;text=Busy+in+the+month+of+May" title="Twitter" class="share share-twitter">
<i
class="fab fa-twitter"></i>
<span>Twitter</span>
</a></li><li
class="li-share-pinterest">
<a
href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;description=Busy+in+the+month+of+May" title="Pinterest" class="share share-pinterest">
<i
class="fab fa-pinterest-p"></i>
<span>Pinterest</span>
</a></li><li
class="li-share-linkedin">
<a
href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;title=Busy+in+the+month+of+May" title="Linkedin" class="share share-linkedin">
<i
class="fab fa-linkedin-in"></i>
<span>Linkedin</span>
</a></li><li
class="li-share-whatsapp">
<a
href="https://api.whatsapp.com/send?phone=&#038;text=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F" title="Whatsapp" class="share share-whatsapp">
<i
class="fab fa-whatsapp"></i>
<span>Whatsapp</span>
</a></li><li
class="li-share-reddit">
<a
href="https://www.reddit.com/submit?url=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F&#038;title=Busy+in+the+month+of+May" title="Reddit" class="share share-reddit">
<i
class="fab fa-reddit-alien"></i>
<span>Reddit</span>
</a></li><li
class="li-share-email">
<a
href="mailto:?subject=Busy%20in%20the%20month%20of%20May&#038;body=https%3A%2F%2Fdailybulldog.com%2Ffeatures%2Fbusy-in-the-month-of-may%2F" title="Email" class="email-share">
<i
class="feather-mail"></i>
<span>Email</span>
</a></li></ul></div></div><div
class="single-component single-component-comment"><div
id="comments" class="comments-area single-section single-component"><h2 class="comments-title single-heading">
<span>
1 Comment		</span></h2><ol
class="commentlist"><li
id="comment-671071" class="comment even thread-even depth-1"><article
id="div-comment-671071" class="comment-body"><footer
class="comment-meta"><div
class="comment-author vcard">
<b
class="fn">Cheryl</b> <span
class="says">says:</span></div><div
class="comment-metadata">
<a
href="https://dailybulldog.com/features/busy-in-the-month-of-may/#comment-671071">
<time
datetime="2021-05-16T17:30:03-04:00">
May 16, 2021 at 5:30 pm							</time>
</a></div></footer><div
class="comment-content"><p>ALL I CAN SAY IS&#8230;&#8230;AMAZING!!!,I WILL ENJOY LOOKING AT THESE OVER AND OVER 🙂 ,THANK YOU ALL!!</p></div></article></li></ol><div
id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title single-heading"><span>Leave a Reply</span> <small><a
rel="nofollow" id="cancel-comment-reply-link" href="/features/busy-in-the-month-of-may/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=busy-in-the-month-of-may#respond" style="display:none;">Cancel reply</a></small></h3><form
action="https://dailybulldog.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p
class="comment-notes">Your email address will not be published.</p><p
class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" placeholder="Write your comment..."></textarea></p><p
class="comment-form-author"><input
id="author" name="author" type="text" value="" size="30" placeholder="Name" /></p><p
class="comment-form-email"><input
id="email" name="email" type="email" value="" size="30" placeholder="Email" /></p><p
class="comment-form-url"><input
id="url" name="url" type="url" value="" size="30" placeholder="Website" /></p><p
class="form-submit"><input
name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input
type='hidden' name='comment_post_ID' value='175891' id='comment_post_ID' />
<input
type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p
style="display: none;"><input
type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2fafad31c5" /></p><input
type="hidden" id="ak_js" name="ak_js" value="71"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div></div></div></div></div></div></div></div></div><aside
id="secondary" class="secondary" role="complementary" itemscope itemptype="https://schema.org/WPSideBar"><div
class="theiaStickySidebar"><div
class="widget-area"><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1128706884"><a
href="http://sellingyourhouseinmaine.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2018/03/coreyhouses.gif" alt=""  width="250" height="125"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-313917031"><a
href="https://www.unitedinsurance.net/"><img
src="https://dailybulldog.com/wp-content/uploads/2017/08/shiretown4.jpg.png" alt=""  width="250" height="123"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-3" class="widget daily-widget"><a
href="https://www.westernmountainfinancial.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2021/01/WMFS-Trust-Matters-DailyBulldog-October-2020-1.gif" alt=""  width="250" height="169"   /></a></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1021625634"><a
href="https://goodtimesrvsales.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2020/06/good-times-1.jpg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-15" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-175178897"><a
href="https://www.ucu.maine.edu/?view=desktop"><img
src="https://dailybulldog.com/wp-content/uploads/2017/07/download-1.png" alt=""  width="324" height="155"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1398026109"><a
href="http://www.wilesrc.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2018/03/basic-block-ad.jpg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-7" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1389918122"><a
href="http://www.seniorplanningcenter.com"><img
src="https://dailybulldog.com/wp-content/uploads/2017/06/download.jpeg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1755047850"><a
href="https://www.seniorsplus.org"><img
src="https://dailybulldog.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-13-at-8.38.24-AM.png" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><a
href="https://fcctf.org/wicked-whoopies/"><img
src="https://dailybulldog.com/wp-content/uploads/2021/04/Untitled-1.jpg" alt=""  width="250" height="120"   /></a></div><div
id="advads_ad_widget-11" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1530779558"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins
class="adsbygoogle" style="display:inline-block;width:250px;height:250px;"
data-ad-client="ca-pub-4057846294512869"
data-ad-slot="0829160850"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({})</script> </div></div><div
id="custom_html-3" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><script type="text/javascript">var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-4957997-1']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=!0;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'.google-analytics.com/ga.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s)})()</script></div></div><div
class="gutter-sidebar"></div></div></div></aside></div></div></article></div><footer
id="wi-footer" class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div
id="footer-widgets" class="footer-widgets footer-sidebar footer-sidebar-1-2-1 skin-light stretch-content valign-stretch"><div
class="container"><div
class="footer-widgets-inner footer-widgets-row"><aside
class="widget-area footer-col col-1-4" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="text-420431207" class="widget widget_text"><h3 class="widget-title"><span>About Us</span></h3><div
class="textwidget"><p>The Daily Bulldog is a completely free, fully online publication dedicated to covering the wide variety of happenings in Franklin County. We aim for timeliness, for our news to go far, and to be a reliable point of information for local residents. For immediate questions and concerns, please call (207) 779-6276 or email <a
href="mailto:thedailybulldog@gmail.com">thedailybulldog@gmail.com </a></p><p><strong><a
href="/aboutus">More About Us</a></strong></p></div></div></div><div
class="footer-col-sep"></div></aside><aside
class="widget-area footer-col col-1-2" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="text-420431210" class="widget widget_text"><h3 class="widget-title"><span>Advertise With Us</span></h3><div
class="textwidget"><p>Daily Bulldog depends on businesses like yours to support our independently owned community paper and news reporting.</p><p>For information on how to advertise please visit our <strong><a
href="https://dailybulldog.com/advertise/">advertising page</a></strong> or contact us at (207) 779-6276 or <a
href="mailto:thedailybulldog@gmail.com">thedailybulldog@gmail.com</a></p></div></div></div><div
class="footer-col-sep"></div></aside><aside
class="widget-area footer-col col-1-4" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="categories-5" class="widget widget_categories"><h3 class="widget-title"><span>Categories</span></h3><form
action="https://dailybulldog.com" method="get"><label
class="screen-reader-text" for="cat">Categories</label><select
name='cat' id='cat' class='postform' ><option
value='-1'>Select Category</option><option
class="level-0" value="3">Arts</option><option
class="level-0" value="4">Business</option><option
class="level-0" value="5">Features</option><option
class="level-0" value="131">Food</option><option
class="level-0" value="12">Happenings</option><option
class="level-0" value="6">Health</option><option
class="level-0" value="7">News</option><option
class="level-0" value="11">Obituaries</option><option
class="level-0" value="8">Opinion</option><option
class="level-0" value="9">Outdoors</option><option
class="level-0" value="10">Sports</option>
</select></form> <script>(function(){var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){dropdown.parentNode.submit()}}
dropdown.onchange=onCatChange})()</script> </div><div
id="archives-4" class="widget widget_archive"><h3 class="widget-title"><span>Archives</span></h3>		<label
class="screen-reader-text" for="archives-dropdown-4">Archives</label>
<select
id="archives-dropdown-4" name="archive-dropdown"><option
value="">Select Month</option><option
value='https://dailybulldog.com/2021/05/'> May 2021</option><option
value='https://dailybulldog.com/2021/04/'> April 2021</option><option
value='https://dailybulldog.com/2021/03/'> March 2021</option><option
value='https://dailybulldog.com/2021/02/'> February 2021</option><option
value='https://dailybulldog.com/2021/01/'> January 2021</option><option
value='https://dailybulldog.com/2020/12/'> December 2020</option><option
value='https://dailybulldog.com/2020/11/'> November 2020</option><option
value='https://dailybulldog.com/2020/10/'> October 2020</option><option
value='https://dailybulldog.com/2020/09/'> September 2020</option><option
value='https://dailybulldog.com/2020/08/'> August 2020</option><option
value='https://dailybulldog.com/2020/07/'> July 2020</option><option
value='https://dailybulldog.com/2020/06/'> June 2020</option><option
value='https://dailybulldog.com/2020/05/'> May 2020</option><option
value='https://dailybulldog.com/2020/04/'> April 2020</option><option
value='https://dailybulldog.com/2020/03/'> March 2020</option><option
value='https://dailybulldog.com/2020/02/'> February 2020</option><option
value='https://dailybulldog.com/2020/01/'> January 2020</option><option
value='https://dailybulldog.com/2019/12/'> December 2019</option><option
value='https://dailybulldog.com/2019/11/'> November 2019</option><option
value='https://dailybulldog.com/2019/10/'> October 2019</option><option
value='https://dailybulldog.com/2019/09/'> September 2019</option><option
value='https://dailybulldog.com/2019/08/'> August 2019</option><option
value='https://dailybulldog.com/2019/07/'> July 2019</option><option
value='https://dailybulldog.com/2019/06/'> June 2019</option><option
value='https://dailybulldog.com/2019/05/'> May 2019</option><option
value='https://dailybulldog.com/2019/04/'> April 2019</option><option
value='https://dailybulldog.com/2019/03/'> March 2019</option><option
value='https://dailybulldog.com/2019/02/'> February 2019</option><option
value='https://dailybulldog.com/2019/01/'> January 2019</option><option
value='https://dailybulldog.com/2018/12/'> December 2018</option><option
value='https://dailybulldog.com/2018/11/'> November 2018</option><option
value='https://dailybulldog.com/2018/10/'> October 2018</option><option
value='https://dailybulldog.com/2018/09/'> September 2018</option><option
value='https://dailybulldog.com/2018/08/'> August 2018</option><option
value='https://dailybulldog.com/2018/07/'> July 2018</option><option
value='https://dailybulldog.com/2018/06/'> June 2018</option><option
value='https://dailybulldog.com/2018/05/'> May 2018</option><option
value='https://dailybulldog.com/2018/04/'> April 2018</option><option
value='https://dailybulldog.com/2018/03/'> March 2018</option><option
value='https://dailybulldog.com/2018/02/'> February 2018</option><option
value='https://dailybulldog.com/2018/01/'> January 2018</option><option
value='https://dailybulldog.com/2017/12/'> December 2017</option><option
value='https://dailybulldog.com/2017/11/'> November 2017</option><option
value='https://dailybulldog.com/2017/10/'> October 2017</option><option
value='https://dailybulldog.com/2017/09/'> September 2017</option><option
value='https://dailybulldog.com/2017/08/'> August 2017</option><option
value='https://dailybulldog.com/2017/07/'> July 2017</option><option
value='https://dailybulldog.com/2017/06/'> June 2017</option><option
value='https://dailybulldog.com/2017/05/'> May 2017</option><option
value='https://dailybulldog.com/2017/04/'> April 2017</option><option
value='https://dailybulldog.com/2017/03/'> March 2017</option><option
value='https://dailybulldog.com/2017/02/'> February 2017</option><option
value='https://dailybulldog.com/2017/01/'> January 2017</option><option
value='https://dailybulldog.com/2016/12/'> December 2016</option><option
value='https://dailybulldog.com/2016/11/'> November 2016</option><option
value='https://dailybulldog.com/2016/10/'> October 2016</option><option
value='https://dailybulldog.com/2016/09/'> September 2016</option><option
value='https://dailybulldog.com/2016/08/'> August 2016</option><option
value='https://dailybulldog.com/2016/07/'> July 2016</option><option
value='https://dailybulldog.com/2016/06/'> June 2016</option><option
value='https://dailybulldog.com/2016/05/'> May 2016</option><option
value='https://dailybulldog.com/2016/04/'> April 2016</option><option
value='https://dailybulldog.com/2016/03/'> March 2016</option><option
value='https://dailybulldog.com/2016/02/'> February 2016</option><option
value='https://dailybulldog.com/2016/01/'> January 2016</option><option
value='https://dailybulldog.com/2015/12/'> December 2015</option><option
value='https://dailybulldog.com/2015/11/'> November 2015</option><option
value='https://dailybulldog.com/2015/10/'> October 2015</option><option
value='https://dailybulldog.com/2015/09/'> September 2015</option><option
value='https://dailybulldog.com/2015/08/'> August 2015</option><option
value='https://dailybulldog.com/2015/07/'> July 2015</option><option
value='https://dailybulldog.com/2015/06/'> June 2015</option><option
value='https://dailybulldog.com/2015/05/'> May 2015</option><option
value='https://dailybulldog.com/2015/04/'> April 2015</option><option
value='https://dailybulldog.com/2015/03/'> March 2015</option><option
value='https://dailybulldog.com/2015/02/'> February 2015</option><option
value='https://dailybulldog.com/2015/01/'> January 2015</option><option
value='https://dailybulldog.com/2014/12/'> December 2014</option><option
value='https://dailybulldog.com/2014/11/'> November 2014</option><option
value='https://dailybulldog.com/2014/10/'> October 2014</option><option
value='https://dailybulldog.com/2014/09/'> September 2014</option><option
value='https://dailybulldog.com/2014/08/'> August 2014</option><option
value='https://dailybulldog.com/2014/07/'> July 2014</option><option
value='https://dailybulldog.com/2014/06/'> June 2014</option><option
value='https://dailybulldog.com/2014/05/'> May 2014</option><option
value='https://dailybulldog.com/2014/04/'> April 2014</option><option
value='https://dailybulldog.com/2014/03/'> March 2014</option><option
value='https://dailybulldog.com/2014/02/'> February 2014</option><option
value='https://dailybulldog.com/2014/01/'> January 2014</option><option
value='https://dailybulldog.com/2013/12/'> December 2013</option><option
value='https://dailybulldog.com/2013/11/'> November 2013</option><option
value='https://dailybulldog.com/2013/10/'> October 2013</option><option
value='https://dailybulldog.com/2013/09/'> September 2013</option><option
value='https://dailybulldog.com/2013/08/'> August 2013</option><option
value='https://dailybulldog.com/2013/07/'> July 2013</option><option
value='https://dailybulldog.com/2013/06/'> June 2013</option><option
value='https://dailybulldog.com/2013/05/'> May 2013</option><option
value='https://dailybulldog.com/2013/04/'> April 2013</option><option
value='https://dailybulldog.com/2013/03/'> March 2013</option><option
value='https://dailybulldog.com/2013/02/'> February 2013</option><option
value='https://dailybulldog.com/2013/01/'> January 2013</option><option
value='https://dailybulldog.com/2012/12/'> December 2012</option><option
value='https://dailybulldog.com/2012/11/'> November 2012</option><option
value='https://dailybulldog.com/2012/10/'> October 2012</option><option
value='https://dailybulldog.com/2012/09/'> September 2012</option><option
value='https://dailybulldog.com/2012/08/'> August 2012</option><option
value='https://dailybulldog.com/2012/07/'> July 2012</option><option
value='https://dailybulldog.com/2012/06/'> June 2012</option><option
value='https://dailybulldog.com/2012/05/'> May 2012</option><option
value='https://dailybulldog.com/2012/04/'> April 2012</option><option
value='https://dailybulldog.com/2012/03/'> March 2012</option><option
value='https://dailybulldog.com/2012/02/'> February 2012</option><option
value='https://dailybulldog.com/2012/01/'> January 2012</option><option
value='https://dailybulldog.com/2011/12/'> December 2011</option><option
value='https://dailybulldog.com/2011/11/'> November 2011</option><option
value='https://dailybulldog.com/2011/10/'> October 2011</option><option
value='https://dailybulldog.com/2011/09/'> September 2011</option><option
value='https://dailybulldog.com/2011/08/'> August 2011</option><option
value='https://dailybulldog.com/2011/07/'> July 2011</option><option
value='https://dailybulldog.com/2011/06/'> June 2011</option><option
value='https://dailybulldog.com/2011/05/'> May 2011</option><option
value='https://dailybulldog.com/2011/04/'> April 2011</option><option
value='https://dailybulldog.com/2011/03/'> March 2011</option><option
value='https://dailybulldog.com/2011/02/'> February 2011</option><option
value='https://dailybulldog.com/2011/01/'> January 2011</option><option
value='https://dailybulldog.com/2010/12/'> December 2010</option><option
value='https://dailybulldog.com/2010/11/'> November 2010</option><option
value='https://dailybulldog.com/2010/10/'> October 2010</option><option
value='https://dailybulldog.com/2010/09/'> September 2010</option><option
value='https://dailybulldog.com/2010/08/'> August 2010</option><option
value='https://dailybulldog.com/2010/07/'> July 2010</option><option
value='https://dailybulldog.com/2010/06/'> June 2010</option><option
value='https://dailybulldog.com/2010/05/'> May 2010</option><option
value='https://dailybulldog.com/2010/04/'> April 2010</option><option
value='https://dailybulldog.com/2010/03/'> March 2010</option><option
value='https://dailybulldog.com/2010/02/'> February 2010</option><option
value='https://dailybulldog.com/2010/01/'> January 2010</option><option
value='https://dailybulldog.com/2009/12/'> December 2009</option><option
value='https://dailybulldog.com/2009/11/'> November 2009</option><option
value='https://dailybulldog.com/2009/10/'> October 2009</option><option
value='https://dailybulldog.com/2009/09/'> September 2009</option><option
value='https://dailybulldog.com/2009/08/'> August 2009</option><option
value='https://dailybulldog.com/2009/07/'> July 2009</option><option
value='https://dailybulldog.com/2009/06/'> June 2009</option><option
value='https://dailybulldog.com/2009/05/'> May 2009</option><option
value='https://dailybulldog.com/2009/04/'> April 2009</option><option
value='https://dailybulldog.com/2009/03/'> March 2009</option><option
value='https://dailybulldog.com/2009/02/'> February 2009</option><option
value='https://dailybulldog.com/2009/01/'> January 2009</option><option
value='https://dailybulldog.com/2008/12/'> December 2008</option><option
value='https://dailybulldog.com/2008/11/'> November 2008</option><option
value='https://dailybulldog.com/2008/10/'> October 2008</option><option
value='https://dailybulldog.com/2008/09/'> September 2008</option><option
value='https://dailybulldog.com/2008/08/'> August 2008</option><option
value='https://dailybulldog.com/2008/07/'> July 2008</option><option
value='https://dailybulldog.com/2008/06/'> June 2008</option></select> <script>(function(){var dropdown=document.getElementById("archives-dropdown-4");function onSelectChange(){if(dropdown.options[dropdown.selectedIndex].value!==''){document.location.href=this.options[this.selectedIndex].value}}
dropdown.onchange=onSelectChange})()</script> </div></div><div
class="footer-col-sep"></div></aside></div></div></div><div
id="footer-bottom" role="contentinfo" class="footer-bottom stretch-content skin-light"><div
class="container"><div
class="classic-footer-bottom classic-footer-bottom-stack"><div
id="footer-logo" class="footer-bottom-element">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Footer Logo" />
</a></div><div
class="social-list footer-social-list footer-bottom-element style-black shape-circle align-center icon-size-normal icon-spacing-small style-none" id="social-id-60a1bcda0dcfc"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div><div
class="footer-search-container footer-bottom-element"><div
class="footer-search" id="footer-search"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div></div><div
class="footer-copyright copyright footer-bottom-element"><p>© 2021 The Daily Bulldog — all rights reserved.<br
/>
Website: <a
href="http://wilderbydesign.com">wilderbydesign</a></p></div><nav
id="footernav" class="footernav footer-bottom-element" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div
class="menu"><ul
id="menu-footer-menu" class="menu"><li
id="menu-item-164834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164834"><a
href="https://dailybulldog.com/advertise/">Advertise</a></li><li
id="menu-item-164835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164835"><a
href="https://dailybulldog.com/about-us/">About Us</a></li><li
id="menu-item-165139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165139"><a
href="https://dailybulldog.com/contact-us/">Contact Us</a></li></ul></div></nav></div></div></div></footer></div><div
class="wrapper-bg-element"></div><div
class="wrapper-border-top hand-border-h wrapper-border"></div><div
class="wrapper-border-bottom hand-border-h wrapper-border"></div><div
class="wrapper-border-left hand-border-v wrapper-border"></div><div
class="wrapper-border-right hand-border-v wrapper-border"></div></div></div><div
id="offcanvas" class="offcanvas offcanvas-light"><div
class="offcanvas-inner"><div
class="offcanvas-search offcanvas-element"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div><nav
id="mobilenav" class="offcanvas-nav offcanvas-element"><div
class="menu"><ul
id="menu-main-menu-1" class="menu"><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6645"><a
href="https://dailybulldog.com/category/news/">News</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-164857"><a
href="https://dailybulldog.com/category/business/">Business</a><span
class="indicator"><i
class="indicator-ic"></i></span><ul
class="sub-menu"><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165089"><a
href="https://dailybulldog.com/business-directory/">Directory</a><span
class="indicator"><i
class="indicator-ic"></i></span></li></ul></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170580"><a
href="https://dailybulldog.com/category/happenings/">Happenings</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164805"><a
href="https://dailybulldog.com/category/arts/">Arts</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171125"><a
href="https://dailybulldog.com/category/food/">Food</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164854"><a
href="https://dailybulldog.com/category/sports/">Sports</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164858"><a
href="https://dailybulldog.com/category/outdoors/">Outdoors</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164859"><a
href="https://dailybulldog.com/category/health/">Health</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164856"><a
href="https://dailybulldog.com/category/obituaries/">Obituaries</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164855"><a
href="https://dailybulldog.com/category/opinion/">Opinion</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-164848"><a
href="https://dailybulldog.com/events/">Events</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164869"><a
href="https://dailybulldog.com/classifieds-2/">Classifieds</a><span
class="indicator"><i
class="indicator-ic"></i></span></li></ul></div></nav><div
class="social-list offcanvas-element style-plain shape-circle align-left icon-size-bigger icon-spacing-small style-none" id="social-id-60a1bcda0f282"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div></div></div><div
id="offcanvas-bg" class="offcanvas-bg"></div><div
class="offcanvas-overlay" id="offcanvas-overlay"></div> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js')})(document.body)</script> <div
id="backtotop" class="backtotop fox-backtotop scrollup backtotop-square backtotop-icon">
<span
class="btt-icon"><i
class="feather-arrow-up"></i></span></div><script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}}</script> <script type="text/javascript" id="pf_script">var pfHeaderImgUrl='';var pfHeaderTagline='';var pfdisableClickToDel='0';var pfImagesSize='full-size';var pfImageDisplayStyle='right';var pfEncodeImages='0';var pfDisableEmail='0';var pfDisablePDF='0';var pfDisablePrint='0';var pfCustomCSS='';var pfPlatform='WordPress'</script> <script async src='https://cdn.printfriendly.com/printfriendly.js'></script> <script id='mediaelement-js-extra'>var _wpmejsSettings={"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"}</script> <script id='wpo_min-footer-0-js-extra'>var wpcf7={"cached":"1"}</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1620056726/assets/wpo-minify-footer-04dd32e9.min.js' id='wpo_min-footer-0-js'></script> <script src='https://dailybulldog.com/wp-includes/js/mediaelement/wp-mediaelement.min.js' id='wp-mediaelement-js'></script> <script id='wpo_min-footer-2-js-extra'>var WITHEMES={"l10n":{"prev":"Previous","next":"Next"},"enable_sticky_sidebar":"","enable_sticky_header":"1","ajaxurl":"https:\/\/dailybulldog.com\/wp-admin\/admin-ajax.php","nonce":"4607b9c213","resturl_v2":"https:\/\/dailybulldog.com\/wp-json\/wp\/v2\/","resturl_v2_posts":"https:\/\/dailybulldog.com\/wp-json\/wp\/v2\/posts\/","tablet_breakpoint":"840","enable_lightbox":"1"}</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1620056726/assets/wpo-minify-footer-92990a93.min.js' id='wpo_min-footer-2-js'></script> <div
id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'))</script> </body></html>