<!DOCTYPE html><html
lang="en-US" class="no-js"><head><meta
charset="UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="profile" href="http://gmpg.org/xfn/11">
<!--[if lt IE 9]> <script src="https://dailybulldog.com/wp-content/themes/fox/js/html5.js"></script> <![endif]--> <script>(function(html){html.className=html.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script> <title>Franklin County Sheriff’s Office weekly report &#8211; Daily Bulldog</title><link
rel='dns-prefetch' href='//fonts.googleapis.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link
rel="alternate" type="application/rss+xml" title="Daily Bulldog &raquo; Feed" href="https://dailybulldog.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="Daily Bulldog &raquo; Comments Feed" href="https://dailybulldog.com/comments/feed/" /><link
rel="alternate" type="text/calendar" title="Daily Bulldog &raquo; iCal Feed" href="https://dailybulldog.com/events/?ical=1" />
 <script src="//www.googletagmanager.com/gtag/js?id=UA-4957997-1"  type="text/javascript" data-cfasync="false"></script> <script type="text/javascript" data-cfasync="false">var mi_version='7.17.0';var mi_track_user=!0;var mi_no_track_reason='';var disableStr='ga-disable-UA-4957997-1';function __gtagTrackerIsOptedOut(){return document.cookie.indexOf(disableStr+'=true')>-1}
if(__gtagTrackerIsOptedOut()){window[disableStr]=!0}
function __gtagTrackerOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';window[disableStr]=!0}
if('undefined'===typeof gaOptout){function gaOptout(){__gtagTrackerOptout()}}
window.dataLayer=window.dataLayer||[];if(mi_track_user){function __gtagTracker(){dataLayer.push(arguments)}
__gtagTracker('js',new Date());__gtagTracker('set',{'developer_id.dZGIzZG':!0,});__gtagTracker('config','UA-4957997-1',{forceSSL:!0,link_attribution:!0,});window.gtag=__gtagTracker;(function(){var noopfn=function(){return null};var newtracker=function(){return new Tracker()};var Tracker=function(){return null};var p=Tracker.prototype;p.get=noopfn;p.set=noopfn;p.send=function(){var args=Array.prototype.slice.call(arguments);args.unshift('send');__gaTracker.apply(null,args)};var __gaTracker=function(){var len=arguments.length;if(len===0){return}
var f=arguments[len-1];if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){if('send'===arguments[0]){var hitConverted,hitObject=!1,action;if('event'===arguments[1]){if('undefined'!==typeof arguments[3]){hitObject={'eventAction':arguments[3],'eventCategory':arguments[2],'eventLabel':arguments[4],'value':arguments[5]?arguments[5]:1,}}}
if(typeof arguments[2]==='object'){hitObject=arguments[2]}
if(typeof arguments[5]==='object'){Object.assign(hitObject,arguments[5])}
if('undefined'!==typeof(arguments[1].hitType)){hitObject=arguments[1]}
if(hitObject){action='timing'===arguments[1].hitType?'timing_complete':hitObject.eventAction;hitConverted=mapArgs(hitObject);__gtagTracker('event',action,hitConverted)}}
return}
function mapArgs(args){var gaKey,hit={};var gaMap={'eventCategory':'event_category','eventAction':'event_action','eventLabel':'event_label','eventValue':'event_value','nonInteraction':'non_interaction','timingCategory':'event_category','timingVar':'name','timingValue':'value','timingLabel':'event_label',};for(gaKey in gaMap){if('undefined'!==typeof args[gaKey]){hit[gaMap[gaKey]]=args[gaKey]}}
return hit}
try{f.hitCallback()}catch(ex){}};__gaTracker.create=newtracker;__gaTracker.getByName=newtracker;__gaTracker.getAll=function(){return[]};__gaTracker.remove=noopfn;__gaTracker.loaded=!0;window.__gaTracker=__gaTracker})()}else{console.log("");(function(){function __gtagTracker(){return null}
window.__gtagTracker=__gtagTracker;window.gtag=__gtagTracker})()}</script> 
<script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}()</script> <link
rel='stylesheet' id='SH_CSS-css'  href='https://dailybulldog.com/wp-content/plugins/SH_CSS/SH_CSS.css?v=6&#038;ver=5.5.4' media='all' /><link
rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://dailybulldog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' media='all' /><link
rel='stylesheet' id='tribe-tooltip-css'  href='https://dailybulldog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' media='all' /><link
rel='stylesheet' id='wp-block-library-css'  href='https://dailybulldog.com/wp-includes/css/dist/block-library/style.min.css' media='all' /><link
rel='stylesheet' id='awesome-weather-css'  href='https://dailybulldog.com/wp-content/plugins/awesome-weather/awesome-weather.css' media='all' /><style id='awesome-weather-inline-css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style><link
rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.5.4' media='all' /><link
rel='stylesheet' id='contact-form-7-css'  href='https://dailybulldog.com/wp-content/plugins/contact-form-7/includes/css/styles.css' media='all' /><link
rel='stylesheet' id='simple-banner-style-css'  href='https://dailybulldog.com/wp-content/plugins/simple-banner/simple-banner.css' media='all' /><link
rel='stylesheet' id='wi-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700%2C800%2C400italic%2C600%7CPathway+Gothic+One%3A400&#038;display=swap&#038;ver=4.6.1.1' media='all' /><link
rel='stylesheet' id='mediaelement-css'  href='https://dailybulldog.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' media='all' /><link
rel='stylesheet' id='wp-mediaelement-css'  href='https://dailybulldog.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' media='all' /><link
rel='stylesheet' id='style-css'  href='https://dailybulldog.com/wp-content/themes/fox/style.min.css' media='all' /><style id='style-inline-css'>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</style><link
rel='stylesheet' id='awpcp-font-awesome-css'  href='https://use.fontawesome.com/releases/v5.2.0/css/all.css' media='all' /><link
rel='stylesheet' id='awpcp-frontend-style-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css' media='all' />
<!--[if lte IE 6]><link
rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css' media='all' />
<![endif]-->
<!--[if lte IE 7]><link
rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://dailybulldog.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css' media='all' />
<![endif]--><link
rel='stylesheet' id='csshero-main-stylesheet-css'  href='https://dailybulldog.com/wp-content/uploads/2021/03/csshero-static-style-fox.css' media='all' /> <script id='wpo_min-header-0-js-extra'>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</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1617729403/assets/wpo-minify-header-c4711bc6.min.js' id='wpo_min-header-0-js'></script> <link
rel="https://api.w.org/" href="https://dailybulldog.com/wp-json/" /><link
rel="alternate" type="application/json" href="https://dailybulldog.com/wp-json/wp/v2/posts/175149" /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dailybulldog.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dailybulldog.com/wp-includes/wlwmanifest.xml" /><link
rel='prev' title='Norlands scholarships open call for applications' href='https://dailybulldog.com/happenings/norlands-scholarships-open-call-for-applications/' /><link
rel='next' title='Politics &#038; Other Mistakes: Old and in the way' href='https://dailybulldog.com/opinion/politics-other-mistakes-old-and-in-the-way-4/' /><meta
name="generator" content="WordPress 5.5.4" /><link
rel='shortlink' href='https://dailybulldog.com/?p=175149' /><link
rel="alternate" type="application/json+oembed" href="https://dailybulldog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://dailybulldog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;format=xml" /><meta
property="fb:app_id" content=""/><meta
property="fb:admins" content=""/><style type="text/css">@media screen{.printfriendly{position:relative;z-index:1000;margin:0 0 0 0}.printfriendly a,.printfriendly a:link,.printfriendly a:visited,.printfriendly a:hover,.printfriendly a:active{font-weight:600;cursor:pointer;text-decoration:none;border:none;-webkit-box-shadow:none;-moz-box-shadow:none;box-shadow:none;outline:none;font-size:14px!important;color:#55750C!important}.printfriendly.pf-alignleft{float:left}.printfriendly.pf-alignright{float:right}.printfriendly.pf-aligncenter{display:flex;align-items:center;justify-content:center}}@media print{.printfriendly{display:none}}</style><style type="text/css" media="screen">.simple-banner{position:initial}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text{font-size:17px}</style><style type="text/css" media="screen">.simple-banner{background:#b5b8ba}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text{color:#fff}</style><style type="text/css" media="screen">.simple-banner .simple-banner-text a{color:#f16521}</style><style id="simple-banner-site-custom-css-dummy" type="text/css" media="screen"></style><script id="simple-banner-site-custom-js-dummy" type="text/javascript"></script><meta
name="tec-api-version" content="v1"><meta
name="tec-api-origin" content="https://dailybulldog.com"><link
rel="https://theeventscalendar.com/" href="https://dailybulldog.com/wp-json/tribe/events/v1/" /><meta
property="og:image" content="https://dailybulldog.com/wp-content/uploads/2021/03/FranklinSheriffBadge-963x1024-2.jpg"/><meta
property="og:image:secure_url" content="https://dailybulldog.com/wp-content/uploads/2021/03/FranklinSheriffBadge-963x1024-2.jpg" /><link
rel="canonical" href="https://dailybulldog.com/news/franklin-county-sheriffs-office-weekly-report-17/" /><style id="wp-custom-css">@media screen and (min-width:568px){body.home li.tribe-events-list-widget-events{width:25%!important;float:left!important}}.tribe-clearfix.tribe-events-category-meetings.tribe-event-featured{border:none!important;margin-top:0!important;margin-bottom:0!important;padding-bottom:0!important}.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event{background-color:transparent!important}</style><style id="color-preview"></style></head><body
class="post-template-default single single-post postid-175149 single-format-standard tribe-no-js page-template-var-www-dailybulldog-com-wp-content-themes-fox-page-php tribe-theme-fox layout-wide style--dropcap-dark dropcap-style-dark style--dropcap-font-heading style--tag-block-2 style--tag-block style--list-widget-1 style--tagcloud-1 style--blockquote-no-icon style--single-heading-border_top style--link-1 elementor-default elementor-kit-164798 aa-prefix-daily-" itemscope itemtype="https://schema.org/WebPage"><div
id="wi-all" class="fox-outer-wrapper fox-all wi-all"><div
id="wi-wrapper" class="fox-wrapper wi-wrapper"><div
class="wi-container"><header
id="masthead" class="site-header header-classic header-sticky-style-shadow submenu-light" itemscope itemtype="https://schema.org/WPHeader"><div
class="header-container header-stack3 header-nav-top-3 header-nav-bottom-1"><div
class="header-classic-row header-row-branding header-row-main header-stack3-main"><div
class="container"><div
id="logo-area" class="fox-logo-area fox-header-logo site-branding"><div
id="wi-logo" class="fox-logo-container"><h2 class="wi-logo-main fox-logo logo-type-image" id="site-logo">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Logo" class="main-img-logo" />
</a></h2></div><h3 class="slogan site-description">Franklin County&#039;s First News</h3></div><div
class="header-stack3-left header-stack3-part">
<a
class="toggle-menu hamburger hamburger-btn">
<i
class="feather-menu"></i>
<i
class="feather-x"></i>
</a><div
class="header-search-wrapper header-search-classic">
<span
class="search-btn-classic search-btn">
<i
class="fa fa-search"></i>    </span><div
class="header-search-form header-search-form-template"><div
class="container"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div></div></div></div><div
class="header-stack3-right header-stack3-part"><div
class="social-list header-social style-plain shape-circle align-center icon-size-normal icon-spacing-small style-none" id="social-id-607d963323f18"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div></div></div></div><div
class="row-nav-light row-nav-style-active-4 header-classic-row header-row-nav header-sticky-element"><div
class="container"><nav
id="wi-mainnav" class="navigation-ele wi-mainnav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div
class="menu style-indicator-angle-down"><ul
id="menu-main-menu" class="menu"><li
id="menu-item-6645" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6645"><a
href="https://dailybulldog.com/category/news/">News</a></li><li
id="menu-item-164857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-164857"><a
href="https://dailybulldog.com/category/business/">Business</a><ul
class="sub-menu"><li
id="menu-item-165089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165089"><a
href="https://dailybulldog.com/business-directory/">Directory</a></li></ul></li><li
id="menu-item-170580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170580"><a
href="https://dailybulldog.com/category/happenings/">Happenings</a></li><li
id="menu-item-164805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164805"><a
href="https://dailybulldog.com/category/arts/">Arts</a></li><li
id="menu-item-171125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171125"><a
href="https://dailybulldog.com/category/food/">Food</a></li><li
id="menu-item-164854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164854"><a
href="https://dailybulldog.com/category/sports/">Sports</a></li><li
id="menu-item-164858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164858"><a
href="https://dailybulldog.com/category/outdoors/">Outdoors</a></li><li
id="menu-item-164859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164859"><a
href="https://dailybulldog.com/category/health/">Health</a></li><li
id="menu-item-164856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164856"><a
href="https://dailybulldog.com/category/obituaries/">Obituaries</a></li><li
id="menu-item-164855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164855"><a
href="https://dailybulldog.com/category/opinion/">Opinion</a></li><li
id="menu-item-164848" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-164848"><a
href="https://dailybulldog.com/events/">Events</a></li><li
id="menu-item-164869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164869"><a
href="https://dailybulldog.com/classifieds-2/">Classifieds</a></li></ul></div></nav></div></div></div><div
id="after-header" class="widget-area header-sidebar wide-sidebar header-row after-header align-center"><div
class="container"><div
class="widget daily-widget"><a
href="https://vaccine.mainehealth.org/join-waitlist?_ga=2.166733246.1844048655.1618240691-1913287870.1567790275"><img
loading="lazy" src="https://dailybulldog.com/wp-content/uploads/2021/01/Rolling-Up-Sleeve-Bulldog-Ad-1200x144revised.png" alt=""  width="1200" height="144"   /></a></div></div></div></header><div
id="masthead-mobile" class="masthead-mobile"><div
class="container"><div
class="masthead-mobile-left masthead-mobile-part">
<a
class="toggle-menu hamburger hamburger-btn">
<i
class="feather-menu"></i>
<i
class="feather-x"></i>
</a></div><h4 id="mobile-logo" class="mobile-logo mobile-logo-image">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Mobile Logo" />
</a></h4><div
class="masthead-mobile-right masthead-mobile-part"></div></div><div
class="masthead-mobile-bg"></div></div><div
id="masthead-mobile-height"></div><div
id="wi-main" class="wi-main fox-main"><article
id="wi-content" class="wi-content wi-single single-style-2 padding-top-normal post-175149 post type-post status-publish format-standard has-post-thumbnail hentry category-news has-sidebar sidebar-right" itemscope itemtype="https://schema.org/CreativeWork"><header
class="single-header post-header entry-header single-big-section align-left single-header-template-4" itemscope itemtype="https://schema.org/WPHeader"><div
class="container"><div
class="header-main"><div
class="post-item-header"><div
class="entry-categories meta-categories categories-plain standalone-categories post-header-section"><a
href="https://dailybulldog.com/category/news/" rel="tag">News</a></div><div
class="title-subtitle"><h1 class="post-title post-item-title">Franklin County Sheriff’s Office weekly report</h1></div><div
class="post-item-meta wi-meta fox-meta post-header-section "><div
class="fox-meta-author entry-author meta-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a
class="meta-author-avatar" itemprop="url" rel="author" href="https://dailybulldog.com/author/administrator/"></a><span
class="byline"> by <span
class="author vcard"><a
class="url fn" itemprop="url" rel="author" href="https://dailybulldog.com/author/administrator/"><span
itemprop="name">Administrator</span></a></span></span></div><div
class="entry-date meta-time machine-time time-short"><time
class="published updated" itemprop="datePublished" datetime="2021-04-19T07:30:53-04:00">April 19, 2021</time></div><div
class="reading-time">13 mins read</div></div></div></div></div></header><div
class="single-big-section single-big-section-content"><div
class="container"><div
id="primary" class="primary content-area"><div
class="theiaStickySidebar"><div
class="single-body single-section"><div
class="single-section single-main-content disable-dropcap"><div
class="entry-container"><div
class="content-main"><div
class="dropcap-content columnable-content entry-content single-component"><div
class="pf-content"><p>Franklin County Sheriff’s Office weekly report for April 10 – 16, 2021:<br
/>
<em>(All persons charged are innocent until proven guilty)</em></p><p>04/10/2021 0851hrs, Deputy Morgan conducted a security detail at a residence on High Street in New Vineyard while a person was removing items from a residence there.</p><p>04/10/2021 1054hrs, Deputy Elmes investigated a complaint of a parent providing marijuana to an adult who was under the age of 21 years old in Kingfield.</p><p>04/10/2021 1438hrs, Deputy Elmes responded to a 911 call at a residence on School Street in Rangeley. The source of the call was not located.</p><p>04/10/2021 1621hrs, Deputy Morgan responded to a parking lot accident at Valley Brook Variety in Avon where Bridgette Magee (45) of Pittston was driving a 2012 Chevy 4d when she backed into protective railing of a gas pump.</p><p>04/10/2021 1634hrs, Deputy Elmes responded to a 911 call at Saddleback Base Lodge in Sandy River Plt. This turned out to be an accidental dial.</p><p>04/10/2021 1741hrs, Deputy Morgan received a complaint of trucks with loud exhausts driving fast and spinning up the road way on Federal Row in Industry.</p><p>04/10/2021 1826hrs, Deputy Morgan responded to a report of a pickup truck stuck in the middle of the Adams Road in Chesterville. The owner stated they are working on retrieving it but not sure even if a wrecker can get at it.</p><p>04/10/2021 1913hrs, Deputy Grey responded to the Rocky Mountain Terrain Park to assist Tr. Monahan with multiple intoxicated individuals whose vehicle was stuck on the road. Tr. Monahan charged the driver with operating under the influence.</p><p>04/10/2021 2005hrs, Deputy Morgan investigated a report of a possible criminal threatening/road rage complaint which occurred on the Farmington Road in Strong. It was alleged that the offender pointed a firearm at the complainant, both complainant and alleged offender were in separate vehicles.</p><p>04/10/2021 2146hrs, Deputy Gray investigated a complaint of harassment on Baker Hill Road in Freeman Twp. The caller claimed that juveniles were banging on their residence. The juveniles were not located.</p><p>04/10/2021 2254hrs, Deputy Morgan investigated a disturbance call between a husband and wife at a residence on the Dixfield Road in Weld. This is an ongoing issue, however no charges were filed.</p><p>04/11/2021 0017hrs, Deputy Gray responded to a 911 call at a residence on the Vienna Road in New Sharon. This turned out to be an accidental dial.</p><p>04/11/2021 0118hrs, Deputy Gray responded to a 911 call on Highland Ave. in Kingfield. This turned out to be an accidental dial.</p><p>04/11/2021 1119hrs, Deputy Elmes serviced a trespass notice on a local man in Rangeley from the Rangeley IGA.</p><p>04/11/2021 1248hrs, Deputy Davol investigated a complaint of a suspicious vehicle on School Street in Weld.</p><p>04/11/2021 1402hrs, Deputy Gray responded to a 911 call at Hannaford’s in Farmington. This turned out to be an accidental dial.</p><p>04/11/2021 1617hrs, Deputy Gray investigated what turned out to be a civil issue regarding a motorcycle on Main Street in New Sharon.</p><p>04/11/2021 1633hrs, Deputy Elmes provided security at a residence on the Kennebago Road in Lang Twp. while a complainant there was removing items from a house of a former spouse.</p><p>04/11/2021 1730hrs, Deputy Elmes received a complaint of possible gunshots from a residence on Axis Mundi Road in Eustis. Deputy Elmes did not find any evidence of a crime.</p><p>04/11/2021 1737hrs, Deputy Gray investigated a report of harassment on the Dodge Road in Phillips. Investigation revealed there was no evidence that a crime had been committed.</p><p>04/12/2021 0912hrs, Deputy Richards conducted a bail check at a residence on the Black Road in Wilton.</p><p>04/11/2021 1009hrs, Deputy Davol received a request to conduct a welfare check on a juvenile on South Main Street in Strong at the request of a grandmother. The child was ok with no issues when located.</p><p>04/12/2021 1131hrs, Deputy Elmes investigated what was originally called in as a theft of a snowmobile trailer on Glidden Road in Eustis, however he learned that the trailer was not stolen only that it appeared someone tried to take it.</p><p>04/12/2021 1155hrs, Deputy Richards received a welfare check request from Mt. Abrams High School regarding students that have not been seen since the fall. Deputy Richards was able to track down the parent of the kids who advised that the kids were attending school in York County. Mt Abram was advised.</p><p>04/12/2021 1312hrs, Deputy Davol responded to a 911 call on the Industry Road in Industry.  The source of the call was not located.</p><p>04/12/2021 1554hrs, Deputy Davol received a complaint of an abandoned vehicle on South Strong Road in Strong. The owner of the vehicle was identified, and the vehicle was parked across the street from the owner’s house.</p><p>04/12/2021 1516hrs, Deputy Richards responded to medical emergency on Blake Hill Road in Phillips. This incident appeared to be drug related and under investigation.</p><p>04/12/2021 1531hrs, Deputy Elmes investigated a possible violation of a protection order at a residence on Blake Hill Road in Phillips. It was discovered that no violation had occurred.</p><p>04/12/2021 2012hrs, Deputy McCormick conducted a probation check at Sherwood Apartments in Farmington. As a result of the check Tina Robinson (27) of Farmington was arrested on a warrant and transported to jail.</p><p>04/13/2021 0747hrs, Deputy Couture assisted a citizen at a residence on the Gloria Road in Farmington with the disposal of some prescription medications.</p><p>04/13/2021 1001hrs, Deputy Morgan conducted a welfare check at a resident at Shadagee senior housing in Phillips at the request of a family friend. Upon arrival he discovered that the person he was checking on was deceased.</p><p>04/13/2021 1302hrs, Lt. Rackliffe responded to a report of a suspicious male at the old school house on the Fairbanks road in Farmington. The male was gone upon arrival.</p><p>03/13/2021 1745hrs, Deputy Gray responded to a 911 call at a residence on Streeter Road in Strong. This was an accidental dial.</p><p>04/13/2021 1944hrs, Deputy Gray received a complaint at the Strong Town Office regarding a clerk who wanted to trespass a resident from the office.</p><p>04/13/2021 2353hrs, Deputy Morgan received a complaint of a suspicious vehicle parked after hours at the Corner Store in Chesterville. The vehicle was broke down and actually belonged to an employee.</p><p>04/14/2021 0840hrs, Deputy Frost responded to a business alarm on Depot Street in Kingfield. This turned out to be a false alarm.</p><p>04/10/2021 1513hrs, Deputy Morgan investigated a complaint of a school bus being passed while it was stopped on the Farmington Road in Strong.</p><p>04/14/2021 1549hrs, Deputy McCormick responded to a medical emergency at a residence on Norton Hill Road in Chesterville.</p><p>04/14/2021hrs 1615hrs, Deputy Morgan responded to a report of a single vehicle accident on the Rangeley Road in Avon. Jesse Longley (45) of Phillips was traveling southbound in a 2016 Ford F-150 when it went off the road, striking a utility pole and snapping it in half, resulting in power and utility lines to fall on top of the vehicle and across the road. Strong Fire and Phillips Fire departments and DOT personnel closed down the road (Route 4) for several hours while CMP cleared the lines.  A juvenile passenger of the Longley vehicle reported minor injuries and was treated at the scene by Northstar personnel. As a result of the investigation, the driver Jesse Longley was arrested on a OUI charge and an endangering the welfare of a child charge and was transported to jail. Farmington Towing hauled the vehicle away.</p><p>04/14/2021 1958hrs, Deputy McCormick responded to a medical emergency at a residence on Cummings Hill road in Temple.</p><p>04/15/2021 0921hrs, Lt. Rackliffe received a complaint on the Gloria Road in New Sharon where a landlord tenant dispute was reported. This is a civil issue.</p><p>04/15/2021 1115hrs, Deputy Frost conducted a welfare check of a couple students at the request of the school district at a residence on School Street in Kingfield. He located the students and determined they were ok.</p><p>04/15/2021 1410hrs, Sgt. Bean and Deputy Couture conducted a probation check at a residence on the Tripp Road in Chesterville.</p><p>04/16/2021 1153hrs, Deputy Davol participated in a community policing event at Mt. Abram High School.</p><p>04/16/2021 1434hrs, Deputy Couture investigated a complaint of harassment via Facebook at a residence on the Adams Road in Chesterville where the complainant wanted a harassment notice served on the alleged offenders.</p><p>04/16/2021 1530hrs, Deputy Elmes responded to a 911 call on Aerie Trail in Sandy River Plt.  This was an accidental dial.</p><p>04/16/2021 1533hrs, Deputy Richards conducted a welfare check at a residence on the River Road in Madrid at the request of a family member. The person was located and was found to be ok.</p><p>04/16/2021 1608hrs, Deputy Richards received a trespass complaint at a residence on Park Street in Phillips.</p><p>04/16/2021 1841hrs, Deputy Elmes responded to a report of a vehicle stuck on Beech Hill Road in Sandy River Plt. Koob’s Wrecker service assisted the vehicle.</p><p>04/16/2021 1849hrs, Deputy Davol investigated a trespassing complaint at a residence on the Adams Road in Chesterville. The alleged offending party of the harassment complaint that was investigated at 1434hrs, requested that deputies serve a no trespass notice on the person who called the police on them.</p><p>04/16/2021 2103hrs, Deputy Richards responded to a medical emergency on Lambert Hill Road in Strong. He assisted personnel from Strong Fire Dept.</p><p>04/16/2021 2145hrs Deputy Richards responded to a report of a single vehicle accident near the ballfield at the intersection of the Farmington Road and Main Street in Strong. Logan Hader (22) of Farmington was driving a 2015 Ford pickup when it jumped the northbound ditch at the intersection taking out a sign. As a result of the investigation Logan Hader was arrested on a charge of OUI and transported to jail.</p><p>04/16/2021 2136hrs, Deputy Davol responded to a car vs. deer accident on Shaw Hill Road in Industry. Freeman Chick (45) of Industry was driving a 2011 Chevy 4dr when the deer collision occurred causing damage to the grill.</p><p>Deputies conducted 59 building checks, all were secure. Deputies also conducted six elder checks.</p><div
class="printfriendly pf-button pf-button-content pf-alignright"><a
href="#" rel="nofollow" onclick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img
style="border:none;-webkit-box-shadow:none; -moz-box-shadow: none; box-shadow:none; padding:0; margin:0" src="https://cdn.printfriendly.com/buttons/printfriendly-button.png" alt="Print Friendly, PDF & Email" /></a></div><style>.pf-button.pf-button-excerpt{display:none}</style></div><div
class="fb-like" data-href="https://dailybulldog.com/news/franklin-county-sheriffs-office-weekly-report-17/" data-layout="standard" data-action="like" data-show-faces="true" data-share="on"></div></div><div
class="single-component single-component-share"><div
class="fox-share share-style-2b share-style-default  background-brand share-layout-stack">
<span
class="share-label"><i
class="fa fa-share-alt"></i>Share this</span><ul><li
class="li-share-facebook">
<a
href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F" title="Facebook" class="share share-facebook">
<i
class="fab fa-facebook-f"></i>
<span>Facebook</span>
</a></li><li
class="li-share-messenger">
<a
href="https://www.facebook.com/dialog/send?app_id=794927004237856&#038;link=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;redirect_uri=https%3A%2F%2Fdailybulldog.com%2F" title="Messenger" class="share share-messenger">
<i
class="fab fa-facebook-messenger"></i>
<span>Messenger</span>
</a></li><li
class="li-share-twitter">
<a
href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;text=Franklin+County+Sheriff%E2%80%99s+Office+weekly+report" title="Twitter" class="share share-twitter">
<i
class="fab fa-twitter"></i>
<span>Twitter</span>
</a></li><li
class="li-share-pinterest">
<a
href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;description=Franklin+County+Sheriff%E2%80%99s+Office+weekly+report" title="Pinterest" class="share share-pinterest">
<i
class="fab fa-pinterest-p"></i>
<span>Pinterest</span>
</a></li><li
class="li-share-linkedin">
<a
href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;title=Franklin+County+Sheriff%E2%80%99s+Office+weekly+report" title="Linkedin" class="share share-linkedin">
<i
class="fab fa-linkedin-in"></i>
<span>Linkedin</span>
</a></li><li
class="li-share-whatsapp">
<a
href="https://api.whatsapp.com/send?phone=&#038;text=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F" title="Whatsapp" class="share share-whatsapp">
<i
class="fab fa-whatsapp"></i>
<span>Whatsapp</span>
</a></li><li
class="li-share-reddit">
<a
href="https://www.reddit.com/submit?url=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F&#038;title=Franklin+County+Sheriff%E2%80%99s+Office+weekly+report" title="Reddit" class="share share-reddit">
<i
class="fab fa-reddit-alien"></i>
<span>Reddit</span>
</a></li><li
class="li-share-email">
<a
href="mailto:?subject=Franklin%20County%20Sheriff%E2%80%99s%20Office%20weekly%20report&#038;body=https%3A%2F%2Fdailybulldog.com%2Fnews%2Ffranklin-county-sheriffs-office-weekly-report-17%2F" title="Email" class="email-share">
<i
class="feather-mail"></i>
<span>Email</span>
</a></li></ul></div></div><div
class="single-component single-component-comment"></div></div></div></div></div></div></div><aside
id="secondary" class="secondary" role="complementary" itemscope itemptype="https://schema.org/WPSideBar"><div
class="theiaStickySidebar"><div
class="widget-area"><div
id="advads_ad_widget-7" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1580520930"><a
href="http://alliedptmaine.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2017/10/allied_pt12.gif" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1363355646"><a
href="https://landing.skowhegan.com/mortgage"><img
src="https://dailybulldog.com/wp-content/uploads/2021/04/Daily-Bulldog-Kristen.png" alt=""  width="250" height="250"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1513777742"><a
href="http://www.franklinchrysler.com/used-inventory/index.htm"><img
src="https://dailybulldog.com/wp-content/uploads/2017/07/frank_chrysler.gif" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-3" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1488883121"><a
href="https://www.hammondlumber.com/free-estimates-deliveries/"><img
src="https://dailybulldog.com/wp-content/uploads/2017/11/download-2.jpeg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1613856297"><a
href="https://www.cunninghampropertyservices.com"><img
src="https://dailybulldog.com/wp-content/uploads/2021/03/Untitled-3.jpg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-15" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1999041025"><a
href="https://www.ucu.maine.edu/?view=desktop"><img
src="https://dailybulldog.com/wp-content/uploads/2017/07/download-1.png" alt=""  width="324" height="155"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-502660936"><a
href="http://www.wilesrc.com/"><img
src="https://dailybulldog.com/wp-content/uploads/2018/03/basic-block-ad.jpg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-227020774"><a
href="https://www.seniorsplus.org"><img
src="https://dailybulldog.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-13-at-8.38.24-AM.png" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1681944807"><a
href="http://www.healthreachchc.org/CurrentOpenings.aspx"><img
src="https://dailybulldog.com/wp-content/uploads/2021/04/Recruitment-04-06.jpg" alt=""  width="250" height="120"  style="display: inline-block;" /></a></div></div><div
id="advads_ad_widget-11" class="widget daily-widget"><div
style="margin-left: auto; margin-right: auto; text-align: center; " id="daily-1577539575"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins
class="adsbygoogle" style="display:inline-block;width:250px;height:250px;"
data-ad-client="ca-pub-4057846294512869"
data-ad-slot="0829160850"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({})</script> </div></div><div
id="custom_html-3" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><script type="text/javascript">var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-4957997-1']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=!0;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'.google-analytics.com/ga.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s)})()</script></div></div><div
class="gutter-sidebar"></div></div></div></aside></div></div></article></div><footer
id="wi-footer" class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div
id="footer-widgets" class="footer-widgets footer-sidebar footer-sidebar-1-2-1 skin-light stretch-content valign-stretch"><div
class="container"><div
class="footer-widgets-inner footer-widgets-row"><aside
class="widget-area footer-col col-1-4" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="text-420431207" class="widget widget_text"><h3 class="widget-title"><span>About Us</span></h3><div
class="textwidget"><p>The Daily Bulldog is a completely free, fully online publication dedicated to covering the wide variety of happenings in Franklin County. We aim for timeliness, for our news to go far, and to be a reliable point of information for local residents. For immediate questions and concerns, please call (207) 779-6276 or email <a
href="mailto:thedailybulldog@gmail.com">thedailybulldog@gmail.com </a></p><p><strong><a
href="/aboutus">More About Us</a></strong></p></div></div></div><div
class="footer-col-sep"></div></aside><aside
class="widget-area footer-col col-1-2" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="text-420431210" class="widget widget_text"><h3 class="widget-title"><span>Advertise With Us</span></h3><div
class="textwidget"><p>Daily Bulldog depends on businesses like yours to support our independently owned community paper and news reporting.</p><p>For information on how to advertise please visit our <strong><a
href="https://dailybulldog.com/advertise/">advertising page</a></strong> or contact us at (207) 779-6276 or <a
href="mailto:thedailybulldog@gmail.com">thedailybulldog@gmail.com</a></p></div></div></div><div
class="footer-col-sep"></div></aside><aside
class="widget-area footer-col col-1-4" itemscope itemptype="https://schema.org/WPSideBar"><div
class="footer-col-inner"><div
id="categories-5" class="widget widget_categories"><h3 class="widget-title"><span>Categories</span></h3><form
action="https://dailybulldog.com" method="get"><label
class="screen-reader-text" for="cat">Categories</label><select
name='cat' id='cat' class='postform' ><option
value='-1'>Select Category</option><option
class="level-0" value="3">Arts</option><option
class="level-0" value="4">Business</option><option
class="level-0" value="5">Features</option><option
class="level-0" value="131">Food</option><option
class="level-0" value="12">Happenings</option><option
class="level-0" value="6">Health</option><option
class="level-0" value="7">News</option><option
class="level-0" value="11">Obituaries</option><option
class="level-0" value="8">Opinion</option><option
class="level-0" value="9">Outdoors</option><option
class="level-0" value="10">Sports</option>
</select></form> <script>(function(){var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){dropdown.parentNode.submit()}}
dropdown.onchange=onCatChange})()</script> </div><div
id="archives-4" class="widget widget_archive"><h3 class="widget-title"><span>Archives</span></h3>		<label
class="screen-reader-text" for="archives-dropdown-4">Archives</label>
<select
id="archives-dropdown-4" name="archive-dropdown"><option
value="">Select Month</option><option
value='https://dailybulldog.com/2021/04/'> April 2021</option><option
value='https://dailybulldog.com/2021/03/'> March 2021</option><option
value='https://dailybulldog.com/2021/02/'> February 2021</option><option
value='https://dailybulldog.com/2021/01/'> January 2021</option><option
value='https://dailybulldog.com/2020/12/'> December 2020</option><option
value='https://dailybulldog.com/2020/11/'> November 2020</option><option
value='https://dailybulldog.com/2020/10/'> October 2020</option><option
value='https://dailybulldog.com/2020/09/'> September 2020</option><option
value='https://dailybulldog.com/2020/08/'> August 2020</option><option
value='https://dailybulldog.com/2020/07/'> July 2020</option><option
value='https://dailybulldog.com/2020/06/'> June 2020</option><option
value='https://dailybulldog.com/2020/05/'> May 2020</option><option
value='https://dailybulldog.com/2020/04/'> April 2020</option><option
value='https://dailybulldog.com/2020/03/'> March 2020</option><option
value='https://dailybulldog.com/2020/02/'> February 2020</option><option
value='https://dailybulldog.com/2020/01/'> January 2020</option><option
value='https://dailybulldog.com/2019/12/'> December 2019</option><option
value='https://dailybulldog.com/2019/11/'> November 2019</option><option
value='https://dailybulldog.com/2019/10/'> October 2019</option><option
value='https://dailybulldog.com/2019/09/'> September 2019</option><option
value='https://dailybulldog.com/2019/08/'> August 2019</option><option
value='https://dailybulldog.com/2019/07/'> July 2019</option><option
value='https://dailybulldog.com/2019/06/'> June 2019</option><option
value='https://dailybulldog.com/2019/05/'> May 2019</option><option
value='https://dailybulldog.com/2019/04/'> April 2019</option><option
value='https://dailybulldog.com/2019/03/'> March 2019</option><option
value='https://dailybulldog.com/2019/02/'> February 2019</option><option
value='https://dailybulldog.com/2019/01/'> January 2019</option><option
value='https://dailybulldog.com/2018/12/'> December 2018</option><option
value='https://dailybulldog.com/2018/11/'> November 2018</option><option
value='https://dailybulldog.com/2018/10/'> October 2018</option><option
value='https://dailybulldog.com/2018/09/'> September 2018</option><option
value='https://dailybulldog.com/2018/08/'> August 2018</option><option
value='https://dailybulldog.com/2018/07/'> July 2018</option><option
value='https://dailybulldog.com/2018/06/'> June 2018</option><option
value='https://dailybulldog.com/2018/05/'> May 2018</option><option
value='https://dailybulldog.com/2018/04/'> April 2018</option><option
value='https://dailybulldog.com/2018/03/'> March 2018</option><option
value='https://dailybulldog.com/2018/02/'> February 2018</option><option
value='https://dailybulldog.com/2018/01/'> January 2018</option><option
value='https://dailybulldog.com/2017/12/'> December 2017</option><option
value='https://dailybulldog.com/2017/11/'> November 2017</option><option
value='https://dailybulldog.com/2017/10/'> October 2017</option><option
value='https://dailybulldog.com/2017/09/'> September 2017</option><option
value='https://dailybulldog.com/2017/08/'> August 2017</option><option
value='https://dailybulldog.com/2017/07/'> July 2017</option><option
value='https://dailybulldog.com/2017/06/'> June 2017</option><option
value='https://dailybulldog.com/2017/05/'> May 2017</option><option
value='https://dailybulldog.com/2017/04/'> April 2017</option><option
value='https://dailybulldog.com/2017/03/'> March 2017</option><option
value='https://dailybulldog.com/2017/02/'> February 2017</option><option
value='https://dailybulldog.com/2017/01/'> January 2017</option><option
value='https://dailybulldog.com/2016/12/'> December 2016</option><option
value='https://dailybulldog.com/2016/11/'> November 2016</option><option
value='https://dailybulldog.com/2016/10/'> October 2016</option><option
value='https://dailybulldog.com/2016/09/'> September 2016</option><option
value='https://dailybulldog.com/2016/08/'> August 2016</option><option
value='https://dailybulldog.com/2016/07/'> July 2016</option><option
value='https://dailybulldog.com/2016/06/'> June 2016</option><option
value='https://dailybulldog.com/2016/05/'> May 2016</option><option
value='https://dailybulldog.com/2016/04/'> April 2016</option><option
value='https://dailybulldog.com/2016/03/'> March 2016</option><option
value='https://dailybulldog.com/2016/02/'> February 2016</option><option
value='https://dailybulldog.com/2016/01/'> January 2016</option><option
value='https://dailybulldog.com/2015/12/'> December 2015</option><option
value='https://dailybulldog.com/2015/11/'> November 2015</option><option
value='https://dailybulldog.com/2015/10/'> October 2015</option><option
value='https://dailybulldog.com/2015/09/'> September 2015</option><option
value='https://dailybulldog.com/2015/08/'> August 2015</option><option
value='https://dailybulldog.com/2015/07/'> July 2015</option><option
value='https://dailybulldog.com/2015/06/'> June 2015</option><option
value='https://dailybulldog.com/2015/05/'> May 2015</option><option
value='https://dailybulldog.com/2015/04/'> April 2015</option><option
value='https://dailybulldog.com/2015/03/'> March 2015</option><option
value='https://dailybulldog.com/2015/02/'> February 2015</option><option
value='https://dailybulldog.com/2015/01/'> January 2015</option><option
value='https://dailybulldog.com/2014/12/'> December 2014</option><option
value='https://dailybulldog.com/2014/11/'> November 2014</option><option
value='https://dailybulldog.com/2014/10/'> October 2014</option><option
value='https://dailybulldog.com/2014/09/'> September 2014</option><option
value='https://dailybulldog.com/2014/08/'> August 2014</option><option
value='https://dailybulldog.com/2014/07/'> July 2014</option><option
value='https://dailybulldog.com/2014/06/'> June 2014</option><option
value='https://dailybulldog.com/2014/05/'> May 2014</option><option
value='https://dailybulldog.com/2014/04/'> April 2014</option><option
value='https://dailybulldog.com/2014/03/'> March 2014</option><option
value='https://dailybulldog.com/2014/02/'> February 2014</option><option
value='https://dailybulldog.com/2014/01/'> January 2014</option><option
value='https://dailybulldog.com/2013/12/'> December 2013</option><option
value='https://dailybulldog.com/2013/11/'> November 2013</option><option
value='https://dailybulldog.com/2013/10/'> October 2013</option><option
value='https://dailybulldog.com/2013/09/'> September 2013</option><option
value='https://dailybulldog.com/2013/08/'> August 2013</option><option
value='https://dailybulldog.com/2013/07/'> July 2013</option><option
value='https://dailybulldog.com/2013/06/'> June 2013</option><option
value='https://dailybulldog.com/2013/05/'> May 2013</option><option
value='https://dailybulldog.com/2013/04/'> April 2013</option><option
value='https://dailybulldog.com/2013/03/'> March 2013</option><option
value='https://dailybulldog.com/2013/02/'> February 2013</option><option
value='https://dailybulldog.com/2013/01/'> January 2013</option><option
value='https://dailybulldog.com/2012/12/'> December 2012</option><option
value='https://dailybulldog.com/2012/11/'> November 2012</option><option
value='https://dailybulldog.com/2012/10/'> October 2012</option><option
value='https://dailybulldog.com/2012/09/'> September 2012</option><option
value='https://dailybulldog.com/2012/08/'> August 2012</option><option
value='https://dailybulldog.com/2012/07/'> July 2012</option><option
value='https://dailybulldog.com/2012/06/'> June 2012</option><option
value='https://dailybulldog.com/2012/05/'> May 2012</option><option
value='https://dailybulldog.com/2012/04/'> April 2012</option><option
value='https://dailybulldog.com/2012/03/'> March 2012</option><option
value='https://dailybulldog.com/2012/02/'> February 2012</option><option
value='https://dailybulldog.com/2012/01/'> January 2012</option><option
value='https://dailybulldog.com/2011/12/'> December 2011</option><option
value='https://dailybulldog.com/2011/11/'> November 2011</option><option
value='https://dailybulldog.com/2011/10/'> October 2011</option><option
value='https://dailybulldog.com/2011/09/'> September 2011</option><option
value='https://dailybulldog.com/2011/08/'> August 2011</option><option
value='https://dailybulldog.com/2011/07/'> July 2011</option><option
value='https://dailybulldog.com/2011/06/'> June 2011</option><option
value='https://dailybulldog.com/2011/05/'> May 2011</option><option
value='https://dailybulldog.com/2011/04/'> April 2011</option><option
value='https://dailybulldog.com/2011/03/'> March 2011</option><option
value='https://dailybulldog.com/2011/02/'> February 2011</option><option
value='https://dailybulldog.com/2011/01/'> January 2011</option><option
value='https://dailybulldog.com/2010/12/'> December 2010</option><option
value='https://dailybulldog.com/2010/11/'> November 2010</option><option
value='https://dailybulldog.com/2010/10/'> October 2010</option><option
value='https://dailybulldog.com/2010/09/'> September 2010</option><option
value='https://dailybulldog.com/2010/08/'> August 2010</option><option
value='https://dailybulldog.com/2010/07/'> July 2010</option><option
value='https://dailybulldog.com/2010/06/'> June 2010</option><option
value='https://dailybulldog.com/2010/05/'> May 2010</option><option
value='https://dailybulldog.com/2010/04/'> April 2010</option><option
value='https://dailybulldog.com/2010/03/'> March 2010</option><option
value='https://dailybulldog.com/2010/02/'> February 2010</option><option
value='https://dailybulldog.com/2010/01/'> January 2010</option><option
value='https://dailybulldog.com/2009/12/'> December 2009</option><option
value='https://dailybulldog.com/2009/11/'> November 2009</option><option
value='https://dailybulldog.com/2009/10/'> October 2009</option><option
value='https://dailybulldog.com/2009/09/'> September 2009</option><option
value='https://dailybulldog.com/2009/08/'> August 2009</option><option
value='https://dailybulldog.com/2009/07/'> July 2009</option><option
value='https://dailybulldog.com/2009/06/'> June 2009</option><option
value='https://dailybulldog.com/2009/05/'> May 2009</option><option
value='https://dailybulldog.com/2009/04/'> April 2009</option><option
value='https://dailybulldog.com/2009/03/'> March 2009</option><option
value='https://dailybulldog.com/2009/02/'> February 2009</option><option
value='https://dailybulldog.com/2009/01/'> January 2009</option><option
value='https://dailybulldog.com/2008/12/'> December 2008</option><option
value='https://dailybulldog.com/2008/11/'> November 2008</option><option
value='https://dailybulldog.com/2008/10/'> October 2008</option><option
value='https://dailybulldog.com/2008/09/'> September 2008</option><option
value='https://dailybulldog.com/2008/08/'> August 2008</option><option
value='https://dailybulldog.com/2008/07/'> July 2008</option><option
value='https://dailybulldog.com/2008/06/'> June 2008</option></select> <script>(function(){var dropdown=document.getElementById("archives-dropdown-4");function onSelectChange(){if(dropdown.options[dropdown.selectedIndex].value!==''){document.location.href=this.options[this.selectedIndex].value}}
dropdown.onchange=onSelectChange})()</script> </div></div><div
class="footer-col-sep"></div></aside></div></div></div><div
id="footer-bottom" role="contentinfo" class="footer-bottom stretch-content skin-light"><div
class="container"><div
class="classic-footer-bottom classic-footer-bottom-stack"><div
id="footer-logo" class="footer-bottom-element">
<a
href="https://dailybulldog.com/" rel="home">
<img
src="https://dailybulldog.com/wp-content/uploads/2020/12/DB_Logo_site.png" alt="Footer Logo" />
</a></div><div
class="social-list footer-social-list footer-bottom-element style-black shape-circle align-center icon-size-normal icon-spacing-small style-none" id="social-id-607d96332cc81"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div><div
class="footer-search-container footer-bottom-element"><div
class="footer-search" id="footer-search"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div></div><div
class="footer-copyright copyright footer-bottom-element"><p>© 2021 The Daily Bulldog — all rights reserved.<br
/>
Website: <a
href="http://wilderbydesign.com">wilderbydesign</a></p></div><nav
id="footernav" class="footernav footer-bottom-element" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div
class="menu"><ul
id="menu-footer-menu" class="menu"><li
id="menu-item-164834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164834"><a
href="https://dailybulldog.com/advertise/">Advertise</a></li><li
id="menu-item-164835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164835"><a
href="https://dailybulldog.com/about-us/">About Us</a></li><li
id="menu-item-165139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165139"><a
href="https://dailybulldog.com/contact-us/">Contact Us</a></li></ul></div></nav></div></div></div></footer></div><div
class="wrapper-bg-element"></div><div
class="wrapper-border-top hand-border-h wrapper-border"></div><div
class="wrapper-border-bottom hand-border-h wrapper-border"></div><div
class="wrapper-border-left hand-border-v wrapper-border"></div><div
class="wrapper-border-right hand-border-v wrapper-border"></div></div></div><div
id="offcanvas" class="offcanvas offcanvas-light"><div
class="offcanvas-inner"><div
class="offcanvas-search offcanvas-element"><div
class="searchform"><form
role="search" method="get" action="https://dailybulldog.com/" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" class="form">
<input
type="text" name="s" class="s search-field" value="" placeholder="Type &amp; hit enter" />
<button
class="submit" role="button" title="Go">
<i
class="fa fa-search"></i>
</button></form></div></div><nav
id="mobilenav" class="offcanvas-nav offcanvas-element"><div
class="menu"><ul
id="menu-main-menu-1" class="menu"><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6645"><a
href="https://dailybulldog.com/category/news/">News</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-164857"><a
href="https://dailybulldog.com/category/business/">Business</a><span
class="indicator"><i
class="indicator-ic"></i></span><ul
class="sub-menu"><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165089"><a
href="https://dailybulldog.com/business-directory/">Directory</a><span
class="indicator"><i
class="indicator-ic"></i></span></li></ul></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170580"><a
href="https://dailybulldog.com/category/happenings/">Happenings</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164805"><a
href="https://dailybulldog.com/category/arts/">Arts</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171125"><a
href="https://dailybulldog.com/category/food/">Food</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164854"><a
href="https://dailybulldog.com/category/sports/">Sports</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164858"><a
href="https://dailybulldog.com/category/outdoors/">Outdoors</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164859"><a
href="https://dailybulldog.com/category/health/">Health</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164856"><a
href="https://dailybulldog.com/category/obituaries/">Obituaries</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164855"><a
href="https://dailybulldog.com/category/opinion/">Opinion</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-164848"><a
href="https://dailybulldog.com/events/">Events</a><span
class="indicator"><i
class="indicator-ic"></i></span></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164869"><a
href="https://dailybulldog.com/classifieds-2/">Classifieds</a><span
class="indicator"><i
class="indicator-ic"></i></span></li></ul></div></nav><div
class="social-list offcanvas-element style-plain shape-circle align-left icon-size-bigger icon-spacing-small style-none" id="social-id-607d96332f2da"><ul><li
class="li-facebook">
<a
href="https://www.facebook.com/DailyBulldog/" target="_blank" rel="alternate" title="Facebook">
<i
class="fab fa-facebook-f"></i>
</a></li><li
class="li-instagram">
<a
href="https://www.instagram.com/dailybulldogedition/" target="_blank" rel="alternate" title="Instagram">
<i
class="fab fa-instagram"></i>
</a></li></ul></div></div></div><div
id="offcanvas-bg" class="offcanvas-bg"></div><div
class="offcanvas-overlay" id="offcanvas-overlay"></div> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js')})(document.body)</script> <div
id="backtotop" class="backtotop fox-backtotop scrollup backtotop-square backtotop-icon">
<span
class="btt-icon"><i
class="feather-arrow-up"></i></span></div><script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}}</script> <script type="text/javascript" id="pf_script">var pfHeaderImgUrl='';var pfHeaderTagline='';var pfdisableClickToDel='0';var pfImagesSize='full-size';var pfImageDisplayStyle='right';var pfEncodeImages='0';var pfDisableEmail='0';var pfDisablePDF='0';var pfDisablePrint='0';var pfCustomCSS='';var pfPlatform='WordPress'</script> <script async src='https://cdn.printfriendly.com/printfriendly.js'></script> <script id='mediaelement-js-extra'>var _wpmejsSettings={"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"}</script> <script id='wpo_min-footer-0-js-extra'>var wpcf7={"cached":"1"}</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1617729403/assets/wpo-minify-footer-04dd32e9.min.js' id='wpo_min-footer-0-js'></script> <script src='https://dailybulldog.com/wp-includes/js/mediaelement/wp-mediaelement.min.js' id='wp-mediaelement-js'></script> <script id='wpo_min-footer-2-js-extra'>var WITHEMES={"l10n":{"prev":"Previous","next":"Next"},"enable_sticky_sidebar":"","enable_sticky_header":"1","ajaxurl":"https:\/\/dailybulldog.com\/wp-admin\/admin-ajax.php","nonce":"7a0161c527","resturl_v2":"https:\/\/dailybulldog.com\/wp-json\/wp\/v2\/","resturl_v2_posts":"https:\/\/dailybulldog.com\/wp-json\/wp\/v2\/posts\/","tablet_breakpoint":"840","enable_lightbox":"1"}</script> <script src='https://dailybulldog.com/wp-content/cache/wpo-minify/1617729403/assets/wpo-minify-footer-2e2505c4.min.js' id='wpo_min-footer-2-js'></script> <div
id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'))</script> </body></html>